<!DOCTYPE html> <html lang="en"> <head data-category_name="social-media" data-content_type="Article" data-original_story="no"> <meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/> <meta name="Generator" content="Greynium CMS"/> <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1"> <title>Elon Musk Hints Twitter Outage Due To Backend Upgrades, Assures Faster Performance -
Gizbot News</title> <meta name="description" content="Around 10,000 people reported issues with Twitter yesterday. The social media platform returned to normal operations in about two hours. Twitter CEO Elon Musk has now indicated the micro-blogging platform was undergoing maintenance and upgrades, which could be the reason Twitter was behaving erratically."/> <meta name="news_keywords" content="Twitter, Elon Musk, Social Media, Down"/> <meta itemprop="keywords" content="Twitter, Elon Musk, Social Media, Down"/> <meta property="og:description" content="Around 10,000 people reported issues with Twitter yesterday. The social media platform returned to normal operations in about two hours. Twitter CEO Elon Musk has now indicated the micro-blogging platform was undergoing maintenance and upgrades, which could be the reason Twitter was behaving erratically."/> <meta itemprop="description" content="Around 10,000 people reported issues with Twitter yesterday. The social media platform returned to normal operations in about two hours. Twitter CEO Elon Musk has now indicated the micro-blogging platform was undergoing maintenance and upgrades, which could be the reason Twitter was behaving erratically."/> <meta property="og:site_name" content="https://www.gizbot.com/"/> <meta itemprop="sourceOrganization" content="Gizbot"/> <meta property="og:type" content="article" data-page_type="article"/> <meta itemprop="name" content="Elon Musk Hints Twitter Outage Due To Backend Upgrades, Assures Faster Performance - Gizbot News"/> <meta itemprop="publisher" content="Gizbot"/> <meta itemprop="editor" content="Gizbot"/> <meta itemprop="inLanguage" content="English"/> <meta itemprop="datePublished" content="2022-12-29T15:56:11+05:30"> <meta itemprop="dateModified" content="2022-12-29T15:56:11+05:30"> <meta property="og:title" content="Elon Musk Hints Twitter Outage Due To Backend Upgrades, Assures Faster Performance"/> <meta itemprop="headline" content="Elon Musk Hints Twitter Outage Due To Backend Upgrades, Assures Faster Performance"/> <meta property="og:url" content="https://www.gizbot.com/social-media/news/elon-musk-twitter-outage-backend-upgrades-faster-performance-084006.html"/> <meta itemprop="url" content="https://www.gizbot.com/social-media/news/elon-musk-twitter-outage-backend-upgrades-faster-performance-084006.html"/> <meta name="robots" content="max-image-preview:large"/> <link rel="image_src" href="https://images.gizbot.com/webp/img/2022/12/elon-musk-twitter-server-upgrade-1672309194.jpg"/> <meta property="og:image" content="https://www.gizbot.com/img/1200x60x675/img/2022/12/elon-musk-twitter-server-upgrade-1672309194.jpg"/> <meta property="fb:app_id" content="1617662258447157"/> <meta property="fb:pages" i content="282027431827699"/> <meta property="article:publisher" content="https://www.facebook.com/gizbot.com"/> <meta name="twitter:card" content="summary_large_image"/> <meta name="twitter:site" content="@gizbot"/> <meta name="twitter:image" content="https://images.gizbot.com/webp/img/2022/12/elon-musk-twitter-server-upgrade-1672309194.jpg?29122022160311"/> <meta name="twitter:title" content="Elon Musk Hints Twitter Outage Due To Backend Upgrades, Assures Faster Performance"/> <meta name="twitter:url" content="https://www.gizbot.com/social-media/news/elon-musk-twitter-outage-backend-upgrades-faster-performance-084006.html?29122022160311"/> <meta name="twitter:description" content="Around 10,000 people reported issues with Twitter yesterday. The social media platform returned to normal operations in about two hours. Twitter CEO Elon Musk has now indicated the micro-blogging platform was undergoing maintenance and upgrades, which could be the reason Twitter was behaving erratically."/> <meta name="twitter:creator" content="gizbot"/> <meta name="twitter:domain" content="https://www.gizbot.com"/> <meta name="DC.date.issued" content="2022-12-29T15:56:11+05:30"/> <meta property="article:author" content="Alap Naik Desai" data-content-src="oi" data-author="Alap Naik Desai" data-match-video="false"/> <meta property="article:published_time" content="2022-12-29T15:56:11+05:30" data-published_date="2022-12-29"/> <meta property="article:modified_time" content="2022-12-29T15:56:11+05:30"/> <meta name="robots" content="index, follow"/> <link rel="shortcut icon" type="image/x-icon" href="/gizbot.ico" sizes="any"> <link rel="icon" href="/gizbot.svg" sizes="any" type="image/svg+xml"> <link rel="canonical" href="https://www.gizbot.com/social-media/news/elon-musk-twitter-outage-backend-upgrades-faster-performance-084006.html"/> <link rel="amphtml" href="https://www.gizbot.com/amphtml/social-media/news/elon-musk-twitter-outage-backend-upgrades-faster-performance-084006.html"> <link href="https://fonts.googleapis.com/icon?family=Material+Icons" rel="stylesheet"> <script type="text/javascript" data-pagespeed-no-defer>window.debugLogs=window.debugLogs||function(logStr,val){try{if(typeof window==='object'){console.log(logStr,val);}}catch(e){}};debugLogs('OICMS - Performance - Page Load Started : ',(performance.now()/1000).toFixed(2)+'seconds');</script> <link rel="preload" href="https://fonts.googleapis.com/css?family=Open+Sans:300,400,600,700" as="font" crossorigin> <link type="text/css" rel="stylesheet" href="/common/adaptive/css/header-footer-style-new.css?v=16"/> <link rel='stylesheet' type='text/css' href="/common/adaptive/css/common-article.css?v=1.0.12"> <style>
.oibuy {
    padding: 0px 0 15px 0;
    text-align: center;
    width: 200px;

}

#right-native-ad img {
    width: 100px;
    height: 75px;
}
iframe.cms-poll-embed {
    border: 0 none;
    width: 100%;
    min-height: 320px;
}
iframe.cms-poll-embed {
    border: 0 none;
}
.smalltxt {
    font-size: 11px!important;
    line-height: 17px!important;
}
.adgNano {
    width: 120px;
    height: 67px;
    float: left;
    padding-right: 10px;
}
li.gal-img1 {
    display: none;
}
li.gal-img2 {
    display: none;
}
.cmscontent-left-article {
    min-height: 275px;
}

.header-ads{
    min-height: 90px;
}

.cmscontent-right1 {
    min-height: 250px;
}
.big_center_img {
    margin-top: 6px!important;
}
.vuukle-powerbar iframe {
    margin-top: 0;
}
.vuukle-powerbar {
    min-height: 52px;
}
.oi-related img {
    width: 120px;
    height: 67px;
}
img.rightArtImg {
    width: 141px;
    height: 79px;
}
div#fwnNewWdg {
    min-height: 300px;
}
img#preview-img {
    width: 600px;
    min-height:337px;
}

.oi-bestphones ul li a .oi-image img {
    width: 40px;
    height:80px;
}

.sixtysec-rightblock {

min-height:184px;

}
</style> <link type="text/css" rel="stylesheet" href="/common/min/?b=common/adaptive/css&f=article-styles.css,article-cl-slider.css,homepage.css,newsletter-popup.css,article-listicle.css,connector.css&v=114"/> <script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "NewsArticle",
    "mainEntityOfPage":{
    "@type":"WebPage",
    "@id":"https://www.gizbot.com/social-media/news/elon-musk-twitter-outage-backend-upgrades-faster-performance-084006.html"
  },
    "headline": "Elon Musk Hints Twitter Outage Due To Backend Upgrades, Assures Faster Performance",
  "url":"https://www.gizbot.com/social-media/news/elon-musk-twitter-outage-backend-upgrades-faster-performance-084006.html",
  "image": {
    "@type": "ImageObject",
    "url": "https://images.gizbot.com/webp/img/2022/12/elon-musk-twitter-server-upgrade-1672309194.jpg",
    "height": 675,
    "width": 1200
 },
  "thumbnailUrl":"https://images.gizbot.com/webp/fit-in/img/128x72/2022/12/elon-musk-twitter-server-upgrade-1672309194.jpg",
  "datePublished": "2022-12-29T15:56:11+05:30",
  "dateModified": "2022-12-29T15:56:11+05:30",
 
  "author": {
    "@type": "Person",
    "url": "https://www.gizbot.com/authors/alapnaikdesai.html",
            "name": "Alap Naik Desai"
  },
  "publisher": {
    "@type": "Organization",
    "name": "Gizbot",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.gizbot.com/images/amp-gizbot-logo.png",
      "width": 354,
      "height": 60
    }
  },
  "articleSection":"News",
  "description": "Around 10,000 people reported issues with Twitter yesterday. The social media platform returned to normal operations in about two hours. Twitter CEO Elon Musk has now indicated the micro-blogging platform was undergoing maintenance and upgrades, which could be the reason Twitter was behaving erratically.",
  "keywords": "Twitter, Elon Musk, Social Media, Down",
  "articleBody":" Twitter had gone down for a few hours yesterday, leaving many users fuming. Around 10,000 people reported issues with the social media platform. Twitter started functioning normally after about two hours. Twitter CEO Elon Musk has now indicated the micro-blogging platform was undergoing maintenance and upgrades. Musk has assured that the Twitter apps should feel a little faster.Twitter Sputters Back to Life After Server Upgrades?Twitter suffered its first-ever major outage after Elon Musk acquired the platform in late October this year. Several thousand users claimed they experienced problems with the site on Wednesday at 7:30 AM EST (6:30 PM IST). DownDetector, a website that tracks site internet traffic and problems tweeted, User reports indicate Twitter has been having problems since 7:13 EST. However, Musk claimed Twitter was working for him by tweeting, works for me, even while users were reporting that they were facing problems accessing the platform.Elon Musk has now indirectly admitted that Twitter was facing some issues in the backend by tweeting the platform was undergoing an upgrade. The Tesla CEO wrote, Significant backend server architecture changes rolled out.Twitter Should Feel Faster Claims MuskElon Musk has assured that the upgrades should improve Twitters performance. While he did not offer any numbers, Musk claimed, Twitter should feel faster.When Twitter users were facing issues logging in or posting tweets, the platforms error message read:Something went wrong, but dont fret -- its not your fault. Lets try again.Twitter faced a similar outage just a few days after Elon Musk had acquired the platform. However, back then, only Twitters desktop or web version failed to work reliably for a few hours. The iOS and Android apps were working normally. Wednesdays outage impacted both the Twitter mobile apps and the desktop or web version."
}


    </script> <script type="application/ld+json">
{
        "@context" : "https://schema.org",
        "@type": "WebPage",
        "description": "Around 10,000 people reported issues with Twitter yesterday. The social media platform returned to normal operations in about two hours. Twitter CEO Elon Musk has now indicated the micro-blogging platform was undergoing maintenance and upgrades, which could be the reason Twitter was behaving erratically." ,
         "url":"https://www.gizbot.com/social-media/news/elon-musk-twitter-outage-backend-upgrades-faster-performance-084006.html",
        "name": "Elon Musk Hints Twitter Outage Due To Backend Upgrades, Assures Faster Performance"
}


    </script> <script type="application/ld+json">
   {"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https:\/\/www.gizbot.com"},{"@type":"ListItem","position":2,"name":"social-media","item":"https:\/\/www.gizbot.com\/social-media\/"},{"@type":"ListItem","position":3,"name":"news","item":"https:\/\/www.gizbot.com\/social-media\/news\/"}]}


    </script> <script data-pagespeed-no-defer>function fetchConsSts(){window.googlefc=window.googlefc||{};window.googlefc.callbackQueue=window.googlefc.callbackQueue||[];return new Promise(resolve=>{googlefc.callbackQueue.push({'CONSENT_DATA_READY':function(){if(typeof googlefc.getAllowAdsStatus!='undefined'){resolve(googlefc.getAllowAdsStatus());}else{resolve(1);}}});});}function globalSetTargetting(event){if(window.googletag&&googletag.apiReady){try{var slotId=event.slot.getSlotElementId();if(document.getElementById(slotId)){var isLoaded=document.getElementById(slotId).getAttribute('data-isloaded');if(isLoaded==1){event.slot.clearTargeting('first_hand');event.slot.setTargeting('first_hand','off');console.log(slotId+" First Hand "+event.slot.getTargeting('first_hand'));}else{event.slot.setTargeting('first_hand','on');console.log(slotId+" First Hand "+event.slot.getTargeting('first_hand'));}document.getElementById(slotId).setAttribute('data-isloaded',1);}}catch(err){console.log("Set Targetting Ad : "+err);}}}function backuprefinery(divId){window.top.r89=window.top.r89||{};window.top.r89.callAds=window.top.r89.callAds||[];console.log(window.top.r89);window.top.r89.callAds.push(function(){window.top.r89.pushAd(divId,'mobile-sticky-footer',[[1,1],[2,2],[300,100],[300,50],[320,100],[320,180],[320,50]]);});}</script> <script data-pagespeed-no-defer>var liteflag=0;if(window.location.search.indexOf('?content=liteversion')>-1){console.log('Liter Version Page...');liteflag=1;}var liteflagFB=0;if(window.location.search.indexOf('ref=fb-instant')>-1){console.log('Liter Version FB Instant Page...');liteflagFB=1;}var backupAdFlag=0;var videoFlag=2;var videoEnableDisableFlag=1;var utmParam1=window.location.search;var utmParamVal=utmParam1.toLowerCase();var icrflagad=false;var rssPromoNotification=1;var host1=window.location.hostname;if(host1!=''&&host1!=undefined){var domainParts1=host1.split('.');var domainmiddle=domainParts1[1];}else{var domainmiddle='oneindia';}var icrflag=1;var domainArr4=['oneindia'];if(domainArr4.indexOf(domainmiddle)>'-1'){var backupAdFlag=4;}if(host1=='bengali.oneindia.com'){var jioAdsenabled=1;var backupAdFlag=3;}else{var jioAdsenabled=0;}console.log("Back Up Ad Flag :"+backupAdFlag);if(jioAdsenabled==1){if(host1.indexOf('filmibeat')>'-1'||host1.indexOf('oneindia')>'-1'){['https://mercury.akamaized.net/jioads/websdk/default/stable/jioAds.js'].forEach(function(src){var script=document.createElement('script');script.src=src;script.async='true';document.head.appendChild(script);});}}var oicamppromo=0;if(utmParamVal!=''&&utmParamVal.includes('utm_medium=camp123')||utmParamVal.includes('utm_medium=prodigital_1')||utmParamVal.includes('utm_medium=apex')||utmParamVal.includes('utm_medium=va')||utmParamVal.includes('utm_medium=proformics')||utmParamVal.includes('utm_medium=ad2click')||utmParamVal.includes('utm_medium=vmedia')){icrflagad=true;var jioAdsenabled=0;if(jioAdsenabled){['https://mercury.akamaized.net/jioads/websdk/default/stable/jioAds.js'].forEach(function(src){var script=document.createElement('script');script.src=src;script.async='true';document.head.appendChild(script);});}var domainArr1=[];if(domainArr1.indexOf(domainmiddle)>'-1'){var icrflag=0;}}var domainArrCamp=['filmibeat','drivespark','goodreturns','oneindia','boldsky','mykhel','careerindia','nativeplanet','gizbot'];if(utmParamVal!=''&&utmParamVal.includes('utm_medium=camp123')||utmParamVal.includes('utm_medium=prodigital_1')||utmParamVal.includes('utm_medium=apex')||utmParamVal.includes('utm_medium=va')||utmParamVal.includes('utm_medium=proformics')||utmParamVal.includes('utm_medium=ZMed')||utmParamVal.includes('utm_medium=vmedia')){if(/Mobi|Android/i.test(navigator.userAgent)){if(domainArrCamp.indexOf(domainmiddle)>'-1'){var jioAdsenabled=0;backupAdFlag=4;icrflagad=false;if(utmParamVal.includes('gam=0')){console.log('No GAM AD');var no_gam=0;icrflagad=true;no_ad_flag=true;var icrflag=0;oicamppromo=0;}else{var no_gam=1;console.log('GAM Inarticle 1 and 2');var icrflag=1;oicamppromo=1;}}}}if(host1=='hindi.oneindia.com'){if(utmParamVal!=''&&utmParamVal.includes('utm_medium=camp123')){if(/Mobi|Android/i.test(navigator.userAgent)){var jioAdsenabled=0;var icrflag=1;oicamppromo=1;}}}if(host1=='tamil.oneindia.com'){if(utmParamVal!=''&&utmParamVal.includes('utm_medium=zmed')){if(/Mobi|Android/i.test(navigator.userAgent)){var jioAdsenabled=0;icrflagad=false;var icrflag=1;oicamppromo=1;}}}console.log(icrflag+' : ICR Flag');var adTimeInterval=30;var adTimeIntervalMobi=10;var refreshTimeOutTimer=30000;var globalTimerVal=30;var refreshFlag=0;var idleFlag=1;var oiadFlag=0;var addRefreshTime=['oneindia'];if(addRefreshTime.indexOf(domainmiddle)>'-1'){var refreshTimeOut=30000;var refreshTimeout=30000;}else{var refreshTimeOut=30000;var refreshTimeout=30000;}if(host1=='tamil.oneindia.com'){var adTimeInterval=15;var adTimeIntervalMobi=10;}if(host1=='kannada.oneindia.com'){var videoFlag=1;}if(/Mobi|Android/i.test(navigator.userAgent)){adTimeInterval=10;}console.log(adTimeInterval+"Ad Time Interval");</script> <style>
.oi-footer-bottom-ad-btns {
    z-index: 999999999;
}
#cubeIframe{
	z-index: 999999!important;
	bottom: 70px!important;
}
#rv_slb {
    z-index: 9999999999!important;
}
.listical-ad-left{
	height: auto!important;
    min-height: 250px;
}
.assigned_video:after {
  display:none!important;
}
.imgBorder {
height: auto;
}
.oiwb {
    word-break: break-word;
}
.amp-fx-flying-carpet {
    height: 350px!important;
}
</style> <link rel="manifest" href="/browser.json?v=1.0.3" pagespeed_no_defer=""> <link href="https://www.google.com/analytics" rel="dns-prefetch"/> <link href="https://www.zedo.com/" rel="dns-prefetch"/> <link href="https://www.doubleclickbygoogle.com/" rel="dns-prefetch"/> <link href="https://adgebra.co.in" rel="dns-prefetch"/> <link href="https://vuukle.com/" rel="dns-prefetch"/> <link href="https://bengali.gizbot.com" rel="dns-prefetch"/> <link href="https://tamil.gizbot.com" rel="dns-prefetch"/> <link href="https://telugu.gizbot.com" rel="dns-prefetch"/> <link href="https://kannada.gizbot.com" rel="dns-prefetch"/> <link href="https://malayalam.gizbot.com" rel="dns-prefetch"/> <link href="https://hindi.gizbot.com" rel="dns-prefetch"/> <link href="https://gujarati.gizbot.com" rel="dns-prefetch"/> <link rel="preconnect" href="https://www.taboola.com/" crossorigin> <link rel="dns-prefetch" href="https://www.taboola.com/"> <meta property="taboola-category" content="english"/> <script type='text/javascript' data-pagespeed-no-defer>var MyApi={};var VUUKLE_CONFIG={};var googletag=googletag||{};googletag.cmd=googletag.cmd||[];var slot=[];var photoGalleryGlobal={};var photoFeatureGlobal={};var clSliderGlobal={};var pf_mobi_slider;var pfGlobalData={};var oi_setting=new Object();var social_share=new Object();var _qevents=_qevents||[];var twitter_via="gizbot";var author_page=new Object();var gf_search_data=new Object();var enabled_noti;var slider_product={};var gaStopCounter=10;var current_url=location.href;var adPerSeen=50;var maxidleRefresh=3;var bottomStickySlot;var PREBID_TIMEOUT_DESK=3000;var PREBID_TIMEOUT_MOBI=3000;if(document.querySelector('meta[property="article:author"]')){var ga_author_name=document.querySelector('meta[property="article:author"]').getAttribute('data-author').trim();}if(document.querySelector('meta[property="article:published_time"]')){var ga_published_date=document.querySelector('meta[property="article:published_time"]').getAttribute('data-published_date').trim();}if(document.querySelector('link[rel="canonical"]')){var canonical_url=document.querySelector('link[rel="canonical"]').getAttribute('href').trim();}if(document.querySelector('meta[property="og:type"]').getAttribute('data-page_type')){var pageType=document.querySelector('meta[property="og:type"]').getAttribute('data-page_type');}var data_match_vdo=false;if(document.querySelector('meta[property="article:author"]')){data_match_vdo=document.querySelector('meta[property="article:author"]').getAttribute('data-match-video').trim();}var direct_ad_refresh=localStorage.getItem("direct_ad");if(direct_ad_refresh==""||direct_ad_refresh=="undefined"||direct_ad_refresh==null){direct_ad_refresh="";}console.log(pageType+"........");</script> <script type='text/javascript' data-pagespeed-no-defer>var promotional_details={promoflag:0,promolink:[''],promolimit:3};</script> <script type='text/javascript' data-pagespeed-no-defer>var zedo_slider=0;var ad_refresh=1;var gutter_ad=0;var non_gutter_ad=1;var com_cnt;var analytics_page_type={"homepage":"index","article":"article","photo feature article":"article-pf","live blog article":"article","photos":"photos","videos":"videos","database":"database"}
var ga_page_type='index';if((document.querySelector('head'))&&(document.querySelector('head').hasAttribute('data-content_type'))){ga_page_type=document.querySelector('head').getAttribute('data-content_type');ga_page_type=ga_page_type.toLowerCase();ga_page_type=analytics_page_type[ga_page_type];if(ga_page_type==undefined||ga_page_type==''||ga_page_type==null){ga_page_type='index';}}console.log(ga_page_type);</script> <script data-pagespeed-no-defer>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');var utmParam=window.location.search.toLowerCase();ga('create','UA-110466-99','auto',{'name':'gizboten'});ga('create','UA-110466-74','auto',{'name':'rosgizbot'});if(ga_author_name!=undefined&&ga_author_name!=""){ga('gizboten.set','dimension1',ga_author_name);}if(ga_published_date!=undefined&&ga_published_date!=""){ga('gizboten.set','dimension3',ga_published_date);}if(pageType!='gadget-finder'){if(canonical_url.length>0){ga('gizboten.set','dimension4',canonical_url);}}var orgstory_value='';if((document.querySelector('head'))&&(document.querySelector('head').hasAttribute('data-original_story'))){orgstory_value=document.querySelector('head').getAttribute('data-original_story');if(orgstory_value==='yes'&&canonical_url.length>0){ga('gizboten.set','dimension6',canonical_url);}}var oi_content_type='';if((document.querySelector('head'))&&(document.querySelector('head').getAttribute('data-content_type'))){oi_content_type=document.querySelector('head').getAttribute('data-content_type');}if(oi_content_type!==undefined&&oi_content_type!==""){}var dimensionPageType=ga_page_type;ga('gizboten.set','dimension8',dimensionPageType);ga('gizboten.send','pageview');ga('rosgizbot.send','pageview');var ga_content_src='';if(document.querySelector('meta[property="article:author"]')&&document.querySelector('meta[property="article:author"]').hasAttribute('data-content-src')){ga_content_src=document.querySelector('meta[property="article:author"]').getAttribute('data-content-src').trim();}if(ga_content_src!=undefined&&ga_content_src!=""){ga('gizboten.set','dimension9',ga_content_src);}var ga_lekhaka_author='';if(document.querySelector('meta[property="article:author"]')&&document.querySelector('meta[property="article:author"]').hasAttribute('data-lekhaka-author')){ga_lekhaka_author=document.querySelector('meta[property="article:author"]').getAttribute('data-lekhaka-author').trim();}if(ga_lekhaka_author!=undefined&&ga_lekhaka_author!=""){ga('gizboten.set','dimension10',ga_lekhaka_author);}ga('create','UA-18423815-11','auto',{'name':'dhglobal','allowLinker':true});ga('dhglobal.require','linker');ga('dhglobal.linker:autoLink',['www.oneindia.com, www.filmibeat.com, www.boldsky.com, www.gizbot.com, www.goodreturns.in, www.drivespark.com, www.mykhel.com, www.careerindia.com, www.nativeplanet.com, www.click.in'],false,true);ga('dhglobal.send','pageview');debugLogs('OICMS - Performance - Analytics Code Ended : ',(performance.now()/1000).toFixed(2)+'seconds');</script> <script>debugLogs('OICMS - Performance - Comscore Code Started : ',(performance.now()/1000).toFixed(2)+'seconds');var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"7732551"});(function(){var s=document.createElement("script"),el=document.getElementsByTagName("script")[0];s.async=true;s.src=(document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s,el);})();debugLogs('OICMS - Performance - Comscore Code Ended : ',(performance.now()/1000).toFixed(2)+'seconds');</script> <script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "potentialAction": {
     "@type": "SearchAction",
     "target": "https://www.gizbot.com/search/results.html?q={search_term_string}",
     "query-input": "required name=search_term_string"
   },
  "name" : "Gizbot",
  "url" : "https://www.gizbot.com",
  "logo": {
      "@type": "ImageObject",
      "url": "https://www.gizbot.com/images/amp-gizbot-logo.png",
      "width": 354,
      "height": 60
    },
  "sameAs" : [ "https://www.facebook.com/gizbot.com",
    "https://twitter.com/gizbot"
   ]
}
</script> <script type="text/javascript" data-pagespeed-no-defer>function redirect_blank(url){var a=document.createElement('a');a.target="_blank";a.href=url;a.click();}function eventTrackerSales(category,action,label){ga('gizboten.send','event',category,action,label);redirect_blank(label);return false;}function setUserCookie(name,value,expires,path,domain,secure){var chkcookiepolicy=getUserCookie('cookiePolicy');console.log(chkcookiepolicy);if(chkcookiepolicy!=0){var today=new Date();today.setTime(today.getTime());if(expires){expires=expires*1000*60*60;}var expires_date=new Date(today.getTime()+(expires));document.cookie=name+'='+escape(value)+((expires)?';expires='+expires_date.toGMTString():'')+((path)?';path='+path:'')+((domain)?';domain='+domain:'')+((secure)?';secure':'');}}function deleteUserCookie(name,path,domain){if(getCookie(name))document.cookie=name+'='+((path)?';path='+path:'')+((domain)?';domain='+domain:'')+';expires=Thu, 01-Jan-1970 00:00:01 GMT';}function checkUserCookie(cookie_name){var location_details=getUserCookie(cookie_name);if(location_details==null||location_details==""){return false;}else if(location_details!=""){return true;}}function getUserCookie(c_name){var c_value=document.cookie;var c_start=c_value.indexOf(" "+c_name+"=");if(c_start==-1){c_start=c_value.indexOf(c_name+"=");}if(c_start==-1){c_value=null;}else{c_start=c_value.indexOf("=",c_start)+1;var c_end=c_value.indexOf(";",c_start);if(c_end==-1){c_end=c_value.length;}c_value=unescape(c_value.substring(c_start,c_end));}return c_value;}</script> <script type="text/javascript" data-pagespeed-no-defer>var utmFlag=1;var utmCamp='';var utmSrc='';var utmMdm='';var utmParam=window.location.search;var utmArr=[];var no_ad_flag=false;if(utmParam!=''){if(icrflag==0||utmParam.includes("utm_medium=prodigital_1")){no_ad_flag=true;utmArr=utmParam.split('&');if(utmArr[0]!=undefined){utmSrc=utmArr[0].split('=')[1];}if(utmArr[1]!=undefined){utmCamp=utmArr[1].split('=')[1];}if(utmArr[2]!=undefined){utmMdm=utmArr[2].split('=')[1];}if(utmArr[3]!=undefined){utmFlag=utmArr[3].split('=')[1];}}}console.log(utmSrc+"A"+utmCamp+"B"+utmMdm+"C"+utmFlag);</script> <script type="text/javascript" data-pagespeed-no-defer>
 //Line Item New Code - Starts
debugLogs('OICMS - Performance - Line Item From RSS API Started : ', (performance.now()/1000).toFixed(2)+'seconds');
var lineItemArr = [];
var sub_array = [];
var sub_array_refresh = [];
  var curHost = window.location.hostname;
  var today = new Date();
  var urlBurstP = today.getHours();
var headers = new Headers();
    headers.append('Content-Type', 'application/json');
    headers.append('cache-control', 'max-age=0, no-cache, no-store, no-transform');
var options = {
    headers: headers
};
var refreshhost = window.location.hostname;
if(refreshhost!='' && refreshhost!=undefined){
  var domainPartsrefresh = refreshhost.split('.');
  var domainmiddlerefresh = domainPartsrefresh[1];
}
var lineItemRefreshVal = '';
var interstitialflag=0;//New Changes Softtonic
var dmflag=0;//New Changes For Video Flag 
	var apiUrl = 'https://rss.oneindia.com/common/oi-line-item-temp.json';
    fetch(apiUrl)
    .then(response => {
      return response.json()
    })
    .then(data => {
        if(data != undefined && data !='' && data != null){
	 //New Changes Softtonic
    if(data['interstritial'].hasOwnProperty('all')){
    			interstitialflag=data['interstritial']['all'];
		}else{
    			interstitialflag=data['interstritial'][refreshhost];
		}
  		console.log("interstritial Promo Host:"+interstitialflag);
      //New Changes Softtonic
//New Changes For Video Flag
    if(data['daily_motion'].hasOwnProperty('all')){
    dmflag=data['daily_motion']['all'];
    }else{
    dmflag=data['daily_motion'][refreshhost];
    }
    console.log("Dm Video Flag:"+dmflag);
//New Changes For Video Flag 
              var jsondata =Object.values(data['line_items']);
              console.log(jsondata);
              var jsonLen = jsondata.length;
              for(j=0;j<jsonLen;j++){
                var webArr = jsondata[j]['websites'];
                if(webArr.includes(curHost) || webArr=='all'){
                  if(webArr=='all'){
                    lineItemRefreshVal = jsondata[j]['refresh']['all'];
                  }else{
                    lineItemRefreshVal = jsondata[j]['refresh'][domainmiddlerefresh];
                  }
                  sub_array.push({'lineitem':jsondata[j]['line_item'],'refreshval':lineItemRefreshVal});
                }
              }
              lineItemArr.push(sub_array);
             console.log(lineItemArr); 
        }
    })
    .catch(err => {
      // Do something for an error here
    })
    //Line Item New Code - Ends
debugLogs('OICMS - Performance - Line Item From RSS API Ended : ', (performance.now()/1000).toFixed(2)+'seconds');
</script> <script>function redirect_blank_ros(url){var a=document.createElement('a');a.target="_blank";a.href=url;a.click();}function eventTrackerSalesROS(category,action,label,url,event){event.stopPropagation();ga('rosgizbot.send','event',category,action,label);redirect_blank_ros(url);return false;}</script> <script type="text/javascript">
	if(window.location.search.indexOf('stoprefresh=1')>-1){
	var ref_logic={"refresh_all":false,"refresh_infinite":false,"idle_refresh_count":3};
	}else{
	var ref_logic={"refresh_all":true,"refresh_infinite":true,"idle_refresh_count":5};
	}
	console.log(ref_logic);
	var cnt = 0;
	var comscoreFlag = 0;
	var triggerComscrore;
	function startInterVal(){
		triggerComscrore = setInterval(function(){
                cnt++;
                if(cnt>=4){
                   comscoreFlag=1; 
                }
            },1000);
	}
	function killInterval(){
		clearInterval(triggerComscrore);
	}
	var pageStats = {
	  startInterVal() {
	    triggerComscrore = setInterval(function(){
	                cnt++;
	                if(cnt>=4){
	                   comscoreFlag=1; 
	                }
	            },1000);
	  },
	  killInterval() {
	    clearInterval(triggerComscrore);
	  }
	};
</script> <style>
#story .refreshInarticleAd iframe {
    width: auto;
    margin-top:0;
}

#story .oiad iframe {
    width: auto;
    margin-top:0;
}
#story .inarticlead iframe {
    width: auto;
    margin-top: 0;
}
iframe#perIframe {
    background: none!important;
    width: 100%;
    margin: 0 auto;
}
.oi-article-lt iframe {
    margin-top: 0px!important;
}
	#div-insticator-ad-1 {
    width: 300px!important;
    overflow-x: hidden;
	}

</style> <script data-pagespeed-no-defer async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script> <script data-pagespeed-no-defer async="async" src="/common/oijs/prebid.js?v=1.0.17"></script> <script pagespeed_no_defer="">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</script> <script data-pagespeed-no-defer>(function(){function f(a,b,d){if(a.addEventListener)a.addEventListener(b,d,!1);else if(a.attachEvent)a.attachEvent("on"+b,d);else{var c=a["on"+b];a["on"+b]=function(){d.call(this);c&&c.call(this)}}};window.pagespeed=window.pagespeed||{};var g=window.pagespeed;function k(a){this.g=[];this.f=0;this.h=!1;this.j=a;this.i=null;this.l=0;this.b=!1;this.a=0}function l(a,b){var d=b.getAttribute("data-pagespeed-lazy-position");if(d)return parseInt(d,0);var d=b.offsetTop,c=b.offsetParent;c&&(d+=l(a,c));d=Math.max(d,0);b.setAttribute("data-pagespeed-lazy-position",d);return d}
function m(a,b){var d,c,e;if(!a.b&&(0==b.offsetHeight||0==b.offsetWidth))return!1;a:if(b.currentStyle)c=b.currentStyle.position;else{if(document.defaultView&&document.defaultView.getComputedStyle&&(c=document.defaultView.getComputedStyle(b,null))){c=c.getPropertyValue("position");break a}c=b.style&&b.style.position?b.style.position:""}if("relative"==c)return!0;e=0;"number"==typeof window.pageYOffset?e=window.pageYOffset:document.body&&document.body.scrollTop?e=document.body.scrollTop:document.documentElement&&
document.documentElement.scrollTop&&(e=document.documentElement.scrollTop);d=window.innerHeight||document.documentElement.clientHeight||document.body.clientHeight;c=e;e+=d;var h=b.getBoundingClientRect();h?(e=h.top-d,c=h.bottom):(h=l(a,b),d=h+b.offsetHeight,e=h-e,c=d-c);return e<=a.f&&0<=c+a.f}
k.prototype.m=function(a){p(a);var b=this;window.setTimeout(function(){var d=a.getAttribute("data-pagespeed-lazy-src");if(d)if((b.h||m(b,a))&&-1!=a.src.indexOf(b.j)){var c=a.parentNode,e=a.nextSibling;c&&c.removeChild(a);a.c&&(a.getAttribute=a.c);a.removeAttribute("onload");a.tagName&&"IMG"==a.tagName&&g.CriticalImages&&f(a,"load",function(){g.CriticalImages.checkImageForCriticality(this);b.b&&(b.a--,b.a||g.CriticalImages.checkCriticalImages())});a.removeAttribute("data-pagespeed-lazy-src");a.removeAttribute("data-pagespeed-lazy-replaced-functions");
c&&c.insertBefore(a,e);if(c=a.getAttribute("data-pagespeed-lazy-srcset"))a.srcset=c,a.removeAttribute("data-pagespeed-lazy-srcset");a.src=d}else b.g.push(a)},0)};k.prototype.loadIfVisibleAndMaybeBeacon=k.prototype.m;k.prototype.s=function(){this.h=!0;q(this)};k.prototype.loadAllImages=k.prototype.s;function q(a){var b=a.g,d=b.length;a.g=[];for(var c=0;c<d;++c)a.m(b[c])}function t(a,b){return a.a?null!=a.a(b):null!=a.getAttribute(b)}
k.prototype.u=function(){for(var a=document.getElementsByTagName("img"),b=0,d;d=a[b];b++)t(d,"data-pagespeed-lazy-src")&&p(d)};k.prototype.overrideAttributeFunctions=k.prototype.u;function p(a){t(a,"data-pagespeed-lazy-replaced-functions")||(a.c=a.getAttribute,a.getAttribute=function(a){"src"==a.toLowerCase()&&t(this,"data-pagespeed-lazy-src")&&(a="data-pagespeed-lazy-src");return this.c(a)},a.setAttribute("data-pagespeed-lazy-replaced-functions","1"))}
g.o=function(a,b){function d(){if(!(c.b&&a||c.i)){var b=200;200<(new Date).getTime()-c.l&&(b=0);c.i=window.setTimeout(function(){c.l=(new Date).getTime();q(c);c.i=null},b)}}var c=new k(b);g.lazyLoadImages=c;f(window,"load",function(){c.b=!0;c.h=a;c.f=200;if(g.CriticalImages){for(var b=0,d=document.getElementsByTagName("img"),r=0,n;n=d[r];r++)-1!=n.src.indexOf(c.j)&&t(n,"data-pagespeed-lazy-src")&&b++;c.a=b;c.a||g.CriticalImages.checkCriticalImages()}q(c)});b.indexOf("data")&&((new Image).src=b);f(window,
"scroll",d);f(window,"resize",d)};g.lazyLoadInit=g.o;})();

pagespeed.lazyLoadInit(true, "/img/loading.gif");
</script></head> <body> <style>
.header-ads {
	min-height: 90px;
}
.header{
	z-index: 9999;
}
</style> <script type="text/javascript">window.google_analytics_uacct="UA-110466-99";</script> <style>
.logo a {
    background: url(/images/gizbot-wt-logo.svg) no-repeat;
    display: block;
    width: 140px;
    padding: 2px 8px;
    height: 35px;
}
.overlay {position: fixed;top: 0;right: 0;left: 0;bottom: 0;background: rgba(0,0,0,0.8);z-index: 100000;}
			.addr-bar {position: fixed;left: 0;top: 0;z-index: 1000000;}
			.arrow {position: fixed;left: 120px;top: 40px;z-index: 1000000;}
			.click-unblock {position: fixed;left: 250px;padding: 20px 10px;background: #0c8043;border: 1px solid #fff;font-size: 14px;color: #fff;font-family: Arial, Helvetica, sans-serif;z-index: 1000000;top: 200px;border-radius: 5px;width: 320px;text-align: center;}
			.click-unblock img {vertical-align: middle;}
			.click-close {position: fixed;right: 100px;padding: 15px 30px;background: #4c4c4c;border: 1px solid #fff;font-size: 14px;color: #fff;font-family: Arial, Helvetica, sans-serif;z-index: 1000000;top: 120px;border-radius: 5px;cursor: pointer;}
			.notf-sampletext {font-size: 16px;color: #fff;font-family: Arial, Helvetica, sans-serif;position: fixed;top: 110px;left: 250px;width: 320px;z-index: 1000000;line-height: 20px;}
			.site {margin: o auto;text-align: center;}
			.subscribe-box {text-align: center;position: fixed;left: 250px;top: 260px;width: 445px;height: 344px;margin: auto;z-index: 1000000;}
			.manage-notification-block-top img {margin: 0;}
</style> <header> <div class="header"> <div class="header-top clearfix"> <div class="header-left"> <div class="logo"><a href="/"></a></div> <div class="giz-lang"> <a href="javascript:void(0);" class="clearfix" id="giz-language"> <span>ENGLISH</span> <i class="material-icons">&#xE5C5;</i> </a> </div> </div> <div class="header-right"> <div class="header-nav"> <nav class="clearfix"> <ul class="clearfix header-nav-left"> <li> <a href="javascript:void(0);" class="clearfix" id="news"> <span>News</span><i class="material-icons">&#xE313;</i> </a> </li> <li> <a href="javascript:void(0);" class="clearfix" id="reviews"> <span>Reviews</span><i class="material-icons">&#xE313;</i> </a> </li> <li> <a href="javascript:void(0);" class="clearfix" id="features"> <span>Features</span><i class="material-icons">&#xE313;</i> </a> </li> <li> <a href="javascript:void(0);" class="clearfix" id="gallery"> <span>Gallery</span><i class="material-icons">&#xE313;</i> </a> </li> <li> <a href="javascript:void(0);" class="clearfix" id="videos"> <span>Videos</span><i class="material-icons">&#xE313;</i> </a> </li> <li> <a href="javascript:void(0);" class="clearfix" id="newdevices"> <span>New Devices</span><i class="material-icons">&#xE313;</i> </a> </li> </ul> <ul class="clearfix header-nav-right"> <li> <a href="javascript:void(0);" class="giz-search clearfix "> <i class="material-icons">&#xE8B6;</i> </a> </li> <li class="notification_bell"> <style type="text/css">
	.overlay {position: fixed;top: 0;right: 0;left: 0;bottom: 0;background: rgba(0,0,0,0.8);z-index: 100000;}
			.addr-bar {position: fixed;left: 0;top: 0;z-index: 1000000;}
			.arrow {position: fixed;left: 120px;top: 40px;z-index: 1000000;}
			.click-unblock {position: fixed;left: 250px;padding: 20px 10px;background: #0c8043;border: 1px solid #fff;font-size: 14px;color: #fff;font-family: Arial, Helvetica, sans-serif;z-index: 1000000;top: 200px;border-radius: 5px;width: 320px;text-align: center;}
			.click-unblock img {vertical-align: middle;}
			.click-close {position: fixed;right: 100px;padding: 15px 30px;background: #4c4c4c;border: 1px solid #fff;font-size: 14px;color: #fff;font-family: Arial, Helvetica, sans-serif;z-index: 1000000;top: 120px;border-radius: 5px;cursor: pointer;}
			.notf-sampletext {font-size: 16px;color: #fff;font-family: Arial, Helvetica, sans-serif;position: fixed;top: 110px;left: 250px;width: 320px;z-index: 1000000;line-height: 20px;}
			.site {margin: o auto;text-align: center;}
			.subscribe-box {text-align: center;position: fixed;left: 250px;top: 260px;width: 445px;height: 344px;margin: auto;z-index: 1000000;}
			.manage-notification-block-top img {margin: 0;}
.manage-notification-block-firefox-content {
    width: 600px;
    position: fixed;
    top: 0;
    left: 0;
    right: 0;
    bottom: 0;
    margin: auto;
    padding: 20px;
    background: #fff;
    z-index: 1000000000;
    height: 320px;
    font-family: Arial;
}
			.manage-notification-block-top-firefox ul {margin-left: 20px;}
			.manage-notification-block-top-firefox ul li {
    padding: 3px 0;
    font-size: 16px;
    color: #000;
    list-style-type: decimal;
}
.manage-notification-heading {font-weight: bold;}
.click-close-firefox {position: fixed;right: 100px;padding: 15px 30px;background: #4c4c4c;border: 1px solid #fff;font-size: 14px;color: #fff;font-family: Arial, Helvetica, sans-serif;z-index: 1000000000;top: 120px;border-radius: 5px;cursor: pointer;}
</style> <div class="nav-notification"> <a href="javascript:void(0);" class="notification-bell ismovement" style="cursor: pointer; display: block; float: left;display: none;" id="notification_bell"><span class="notification-num" style="display: none;"></span><img src="/images/bell-blk.svg" width="25" height="25"></a> </div> <div class="nav-notification"> <a href="javascript:void(0);" class="notification-bell-inactive" style="cursor: pointer;float: left; display: none;" id="notification_bell_inactive"><img src="/images/bell-1.svg" width="25" height="25"></a> </div> <div class="manage-notification" style="display: none;"> <div class="manage-notification-close"> <i class="fa fa-close"></i> </div>
You can manage your notification subscription by clicking on the icon
</div> <div class="manage-notification-block-top" style="display: none;"> <div class="addr-bar"><img src="https://images.oneindia.com/notification/images/addr-bar.png?q=1" alt="" data-pagespeed-no-defer /></div> <div class="overlay" style=""></div> <div class="arrow"><img src="https://images.oneindia.com/notification/images/arrow1.png" alt="" data-pagespeed-no-defer /></div> <div class="notf-sampletext">To start receiving timely alerts, as shown below click on the Green “lock” icon next to the address bar</div> <div class="click-unblock"><img src="https://images.oneindia.com/notification/images/lock.png" alt="" data-pagespeed-no-defer /> Click it and Unblock the Notifications</div> <div class="click-close">Close X</div> <div class="subscribe-box"><img src="https://images.oneindia.com/notification/images/subscribe-box.png" alt="" data-pagespeed-no-defer /></div> </div> <div class="manage-notification-block-top-firefox" style="display: none;"> <div class="overlay" style=""></div> <div class="click-close-firefox">Close X</div> <div class="manage-notification-block-firefox-content"> <div class="manage-notification-heading">To Start receiving timely alerts please follow the below steps:</div> <ul> <li>Click on the Menu icon of the browser, it opens up a list of options.</li> <li>Click on the “Options ”, it opens up the settings page,</li> <li>Here click on the “Privacy & Security” options listed on the left hand side of the page.</li> <li>Scroll down the page to the “Permission” section .</li> <li>Here click on the “Settings” tab of the Notification option.</li> <li>A pop up will open with all listed sites, select the option “ALLOW“, for the respective site under the status head to allow the notification.</li> <li>Once the changes is done, click on the “Save Changes” option to save the changes.</li> </ul> </div> </div> <div class="notification-wrapper" style="display: none;"> <div class="notification-arrow"></div> <div class="popup-notification-header clearfix"> <div class="popup-notification-text"> <i class="fa fa-arrow-left"></i> Notifications
</div> <div class="popup-notification-on-off onstate"> <span class="on-off-link"></span> </div> </div> <div class="notification-content"> <div id="notf-cont"> <div class="notification-clear"><a href="javascript:void(0);">Clear All</a></div> <ul id="not-content"></ul> </div> <div class="notification-text" style="display: none;">No Notifications</div> </div> </div> </li> </ul> </nav> <div class="giz-search-block" style="display: none;"> <a href="javascript:void(0);" class="giz-close clearfix "> <i class="material-icons">&#xE5CD;</i> </a> <div class="search-input"> <input type="text" placeholder="search" id="searchBox"/> </div> <a href="javascript:void(0);" class="clearfix giz-search"> <i class="material-icons">&#xE8B6;</i> </a> </div> <div class="giz-share-block"> <a href="javacsript:void(0)" class="share-fb"><i class="fa fa-facebook-f"></i></a> <a href="javacsript:void(0)" class="share-twitter"><i class="fa fa-twitter"></i></a> </div> </div> </div> </div> <div class="header-nav-show"> <div id="giz-language-block"> <ul class="clearfix"> <li> <span class="allLanguages">Also available in:</span> </li> <li> <a href="https://hindi.gizbot.com/" target="_blank" class="lang-hindi">हिन्दी</a> </li> <li> <a href="https://kannada.gizbot.com/" target="_blank" class="lang-kannada">ಕನ್ನಡ</a> </li> <li> <a href="https://malayalam.gizbot.com/" target="_blank" class="lang-malyalam">മലയാളം</a> </li> <li> <a href="https://tamil.gizbot.com/" target="_blank" class="lang-tamil">தமிழ்</a> </li> <li> <a href="https://telugu.gizbot.com/" target="_blank" class="lang-telugu">తెలుగు</a> </li> <li> <a href="https://bengali.gizbot.com/" target="_blank" class="lang-bengali">বাংলা</a> </li> <li> <a href="https://gujarati.gizbot.com/" target="_blank" class="lang-gujarati last">ગુજરાતી</a> </li> </ul> </div> </div> <div class="giz-sub-sec-menu" itemscope="" itemtype="https://www.schema.org/SiteNavigationElement"> <div class="giz-sub-menu-block news-block"> <h3><a href="/news/">News</a></h3> <ul class="clearfix"> <li> <a href="/mobile/news/" itemprop="url"><span itemprop="name">Mobile </span></a> </li> <li> <a href="/telecom/news/" itemprop="url"><span itemprop="name">Telecom</span></a> </li> <li> <a href="/wearable-technology/news/" itemprop="url"><span itemprop="name">Wearables</span></a> </li> <li> <a href="/home-entertainment/news/" itemprop="url"><span itemprop="name">Home-Entertainment</span></a> </li> <li> <a href="/apps/news/" itemprop="url"><span itemprop="name">Apps</span></a> </li> <li> <a href="/laptop/news/" itemprop="url"><span itemprop="name">Laptop</span></a> </li> <li> <a href="/camera/news/" itemprop="url"><span itemprop="name">Camera</span></a> </li> <li> <a href="/tablet/news/" itemprop="url"><span itemprop="name">Tablet</span></a> </li> <li> <a href="/gaming/" itemprop="url"><span itemprop="name">Gaming</span></a> </li> <li> <a href="/internet/news/" itemprop="url"><span itemprop="name">Internet</span></a> </li> <li> <a href="/computer/news/" itemprop="url"><span itemprop="name">Computer</span></a> </li> <li> <a href="/miscellaneous/" itemprop="url"><span itemprop="name">Miscellaneous</span></a> </li> <li> <a href="/deal-of-the-day/" itemprop="url"><span itemprop="name">Deal Of The Day</span></a> </li> </ul> </div> <div class="giz-sub-menu-block reviews-block"> <h3><a href="/reviews/">Reviews</a></h3> <ul class="clearfix"> <li> <a href="/mobile/reviews/" itemprop="url"><span itemprop="name">Mobiles</span></a> </li> <li> <a href="/wearable-technology/reviews/" itemprop="url"><span itemprop="name">Wearables</span></a> </li> <li> <a href="/home-entertainment/reviews/" itemprop="url"><span itemprop="name">Home-Entertainment</span></a> </li> <li> <a href="/apps/reviews/" itemprop="url"><span itemprop="name">Apps</span></a> </li> <li> <a href="/laptop/reviews/" itemprop="url"><span itemprop="name">Laptops/PC</span></a> </li> <li> <a href="/tablet/reviews/" itemprop="url"><span itemprop="name">Tablets</span></a> </li> <li> <a href="/computer/reviews/" itemprop="url"><span itemprop="name">Computer</span></a> </li> </ul> </div> <div class="giz-sub-menu-block features-block"> <h3><a href="/features/">Features</a></h3> <ul class="clearfix"> <li> <a href="/how-to/tips-tricks/" itemprop="url"><span itemprop="name">Tips and Tricks</span></a> </li> <li> <a href="/mobile/features/" itemprop="url"><span itemprop="name">Mobile Feature</span></a> </li> <li> <a href="/wearable-technology/features/" itemprop="url"><span itemprop="name">Wearable Feature</span></a> </li> <li> <a href="/how-to/" itemprop="url"><span itemprop="name">How-To</span></a> </li> <li> <a href="/social-media/features/" itemprop="url"><span itemprop="name">Social Media Feature</span></a> </li> <li> <a href="/apps/features/" itemprop="url"><span itemprop="name">Apps Feature</span></a> </li> <li> <a href="/internet/features/" itemprop="url"><span itemprop="name">Internet Features</span></a> </li> <li> <a href="/computer/features/" itemprop="url"><span itemprop="name">Computer Features</span></a> </li> <li> <a href="/laptop/features/" itemprop="url"><span itemprop="name">Laptop Features</span></a> </li> <li> <a href="/tablet/features/" itemprop="url"><span itemprop="name">Tablet Features</span></a> </li> </ul> </div> <div class="giz-sub-menu-block gallery-block"> <h3><a href="/photos/">Gallery</a></h3> <ul class="clearfix"> <li> <a href="https://www.gizbot.com/photos/mobiles/" itemprop="url"><span itemprop="name">Mobiles</span></a> </li> <li> <a href="https://www.gizbot.com/photos/concepts/" itemprop="url"><span itemprop="name">Concepts</span></a> </li> <li> <a href="https://www.gizbot.com/photos/laptops/" itemprop="url"><span itemprop="name">Laptops</span></a> </li> <li> <a href="https://www.gizbot.com/photos/events/" itemprop="url"><span itemprop="name">Events</span></a> </li> <li> <a href="https://www.gizbot.com/photos/camera/" itemprop="url"><span itemprop="name">Cameras</span></a> </li> <li> <a href="https://www.gizbot.com/photos/tablets/" itemprop="url"><span itemprop="name">Tablets</span></a> </li> </ul> </div> <div class="giz-sub-menu-block videos-block"> <h3><a href="/videos/">Videos</a></h3> <ul class="clearfix"> <li> <a href="/videos/reviews/" itemprop="url"><span itemprop="name">Reviews</span></a> </li> <li> <a href="/videos/howto/" itemprop="url"><span itemprop="name">How-to</span></a> </li> <li> <a href="/videos/first-impressions/" itemprop="url"><span itemprop="name">First Impression</span></a> </li> <li> <a href="https://www.gizbot.com/videos/unboxing/" itemprop="url"><span itemprop="name">Unboxing</span></a> </li> <li> <a href="https://www.gizbot.com/videos/interviews/" itemprop="url"><span itemprop="name">Interviews</span></a> </li> <li> <a href="/videos/features/" itemprop="url"><span itemprop="name">Features</span></a> </li> </ul> </div> <div class="giz-sub-menu-block newdevices-block"> <h3><a href="/gadget-finder/">New Devices</a></h3> <ul class="clearfix"> <li> <a href="https://www.gizbot.com/new-mobiles/" itemprop="url"><span itemprop="name"> Mobiles</span></a> </li> <li> <a href="https://www.gizbot.com/new-laptops/" itemprop="url"><span itemprop="name"> Laptops</span></a> </li> <li> <a href="https://www.gizbot.com/new-cameras/" itemprop="url"><span itemprop="name"> Cameras</span></a> </li> <li> <a href="https://www.gizbot.com/smart-tv/" itemprop="url"><span itemprop="name">Smart TV</span></a> </li> <li> <a href="/latest-mobiles/" itemprop="url"><span itemprop="name">Latest Mobiles</span></a> </li> <li> <a href="/upcoming-mobiles/" itemprop="url"><span itemprop="name">Upcoming Mobiles</span></a> </li> <li> <a href="/new-mobiles/compare/" itemprop="url"><span itemprop="name">Compare Mobiles</span></a> </li> <li> <a href="/top-10-mobiles/" itemprop="url"><span itemprop="name">Top 10 Mobiles</span></a> </li> </ul> </div> </div> </div> </header> <div class="cmscontent-top inhouse-content" style="display:block;" id="cmscontent-top" data-zoneId='{"backfill":"87","inhouse":"81"}' data-reviveId='{"backfill":"9de4f035bc8106094a8824fc0cfb6de3","inhouse":"9de4f035bc8106094a8824fc0cfb6de3"}'> <div class="header-post" style="text-align: center;padding-top: 60px;"> <div id="ATF_728x90" data-cb-ad-id="gizbot-728x90" class="header-ads"> <div id='div-gpt-ad-1384320856135-5' class="oiad1 oi-axt" data-adval=0 data-elementid="0" data-exec=0></div> <div id='div-gpt-ad-1384320856135-2' class="oiad1 oi-axt" data-adval=0 data-elementid="0" data-exec=0></div> </div> <div id="photo_ad_head_second"></div> </div> </div> <div id='div-gpt-ad-1435639807102-1' style='height:1px; width:1px;'></div> <div id='div-gpt-ad-1571219971764-1'></div> <style>
.oiOverlay {

        border: 0px;
        vertical-align: bottom;
        position: fixed;
        bottom: 10px;
        right: 30px;
        z-index: 999999999;
        width: 100%;
        height: 100%;

}
.oiOverlay iframe {
 display: block;       / iframes are inline by default /

    border: none;         / Reset default border /
    height: 100vh;        / Viewport-relative units /
    width: 100vw;

}

</style> <div id="wrapper" data-slideshow="false" data-video-flag="false"> <div id="containerMain" data-content_id="84006" data-deeplink_flag="0" data-video-info="" data-page_type="article" data-video-position="" data-adcont_identity="false" data-comments="yes"></div> <div id="container" data-con_line="/social-media/news/" data-content_id="84006" data-category_name="social-media" data-category_id="16519"> <div class="article"> <div class="left-container"> <article> <div class="left-container-content"> <section> <div class="content-article" style="overflow: hidden;"> <div class="article-contents-block"> <article> <div class="ecom-ad-content io-article-body"> <div class="oi-article-lt"><style type="text/css">
        .giz-view-sample.open a {
     position: relative;
    right: 5px;
    padding: 5px 0;
}
.giz-view-sample a {
    padding: 5px 0;
     display: block;
    position: relative;
}
.sub-btn{
        display: block;
    height: 40px;
    line-height: 40px;
    text-align: center;
    width: 100%;
    background: #000000;
    color: #ffffff;
    outline: none;
    border: none;
    cursor: pointer;
}
</style> <div style="margin:13px 0;width:300px;display:none;" id="giz-subscribe"> <div class="giz-subscribe" id="giz-subscribe"> <div class="giz-subscribe-head">
For Quick Alerts
</div> <div class="giz-subscribe-block">
Subscribe Now
<a href="javascript:void(0);" class="notification-bell" id="notification_bell_left"> <i class="bell-icon"></i> </a> </div> <div class="giz-view-sample"> <div class="giz-sample-article"> <div class="sample-image"> <a href="https://www.gizbot.com/mobile/features/last-week-most-trending-smartphones-samsung-galaxy-s22-ultra-5g-galaxy-s22-5g-redmi-note-11-079207.html" target="_blank"> <picture> <source srcset="https://images.gizbot.com/webp/img/70x70/2022/02/last-week-most-trending-smartphones-samsung-galaxy-s22-ultra-5g-galaxy-s22-5g-redmi-note-11-1644846194.jpg"> <source srcset="https://images.gizbot.com/png/img/70x70/2022/02/last-week-most-trending-smartphones-samsung-galaxy-s22-ultra-5g-galaxy-s22-5g-redmi-note-11-1644846194.jpg"> <img data-pagespeed-lazy-src="https://images.gizbot.com/img/70x70/2022/02/last-week-most-trending-smartphones-samsung-galaxy-s22-ultra-5g-galaxy-s22-5g-redmi-note-11-1644846194.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/> </picture> </a> </div> <div class="sample-text"> <a href="https://www.gizbot.com/mobile/features/last-week-most-trending-smartphones-samsung-galaxy-s22-ultra-5g-galaxy-s22-5g-redmi-note-11-079207.html" target="_blank">
Last Week Most Trending Smartphones: Samsung Galaxy S22 Ultra 5G, Galaxy S22 5G, Redmi Note 11, And More
</a> </div> <div class="clearfix"></div> </div> <div class="gizbot-sample-link"> <a href="javascript:void(0);">View Sample</a> </div> </div> </div> </div> <div style="margin:13px 0;width:300px;display:none;" id="giz-unsubscribe"> <div class="giz-subscribe block"> <div class="giz-subscribe-head">
For Quick Alerts
</div> <div class="giz-subscribe-block">
ALLOW NOTIFICATIONS
<a href="javascript:void(0);" id="notification_bell_unsub" class="notification_bell_unsub"> <i class="bell-icon"></i> </a> </div> </div> </div> <div style="margin:13px 0;width:300px;display:none;" id="giz-emailsubscribe"> <div class="giz-subscribe block"> <div class="giz-subscribe-head">
For Daily Alerts
</div> <div class="giz-subscribe-block"> <form target="_blank" class="nospace" action="https://app5.saymails.com/cgi-bin/useradd.pl" method="post" name="newsletter_subscribeform" id="newsletter"> <input type="hidden" name="city" id="newsletter_city"> <input type="hidden" name="country" id="newsletter_country"> <input type="hidden" name="dbname1" value="b25laW5kaWE="> <input type="hidden" name="listname1" value="Z2l6Ym90"> <input type="hidden" name="action1" value="useradd"> <div class="giz-subscribe-textbox"> <input type="text" name="email" placeholder="Enter Your Email Address" class="newsletter-textbox" id="email"> </div> <div class="giz-subscribe-button"> <input type="submit" name="subscribe" value="Sign Up" onclick="return postformById('useradd',this.form);" class="sub-btn"> </div> </form> </div> </div> </div> <div class="cmscontent-left-article inhouse-content" id="cmscontent-left-article" data-zoneid='{"inhouse":77,"backfill":83}' data-reviveid='{"inhouse":"9de4f035bc8106094a8824fc0cfb6de3","backfill":"9de4f035bc8106094a8824fc0cfb6de3"}'> <div id="div-gpt-ad-1430818098224-6" class="oiad inArticleRight oi-axt" data-exec=0 data-adval=0 data-elementid='3'></div> </div> <div class="oi-related"> <h2 class="oi-left-heading">Just In <i class="watch-icon"></i></h2> <ul> <li class="clearfix"> <span class="timestamp">2 hrs ago</span> <a href="/mobile/news/moto-e13-design-leaked-084005.html" data-uparam="ref_medium=Desktop&ref_source=GB-EN&ref_campaign=Left_Include" class="col-block oiHyperLink"> <picture> <source srcset="https://images.gizbot.com/webp/fit-in/img/157x88/2022/12/moto-e13-1-1672299350.jpg"> <source srcset="https://images.gizbot.com/png/fit-in/img/157x88/2022/12/moto-e13-1-1672299350.jpg"> <img src="https://images.gizbot.com/fit-in/img/157x88/2022/12/moto-e13-1-1672299350.jpg" alt="Moto E13 Design Leaked; Could Launch In India Soon " class="lazy"/> </picture> </a> <a href="/mobile/news/moto-e13-design-leaked-084005.html" data-uparam="ref_medium=Desktop&ref_source=GB-EN&ref_campaign=Left_Include" class="os-short-text oiHyperLink">Moto E13 Design Leaked; Could Launch In India Soon </a> </li> <li class="clearfix"> <span class="timestamp">3 hrs ago</span> <a href="/gadgets/news/home-assistant-get-own-voice-assistant-control-smart-gadgets-without-siri-alexa-google-084004.html" data-uparam="ref_medium=Desktop&ref_source=GB-EN&ref_campaign=Left_Include" class="col-block oiHyperLink"> <picture> <source srcset="https://images.gizbot.com/webp/fit-in/img/157x88/2022/12/home-assistant-voice-1672298187.jpg"> <source srcset="https://images.gizbot.com/png/fit-in/img/157x88/2022/12/home-assistant-voice-1672298187.jpg"> <img src="https://images.gizbot.com/fit-in/img/157x88/2022/12/home-assistant-voice-1672298187.jpg" alt="Home Assistant To Get Its Own Voice Assistant: Control Smart Gadgets Without Siri, Alexa, or Google" class="lazy"/> </picture> </a> <a href="/gadgets/news/home-assistant-get-own-voice-assistant-control-smart-gadgets-without-siri-alexa-google-084004.html" data-uparam="ref_medium=Desktop&ref_source=GB-EN&ref_campaign=Left_Include" class="os-short-text oiHyperLink">Home Assistant To Get Its Own Voice Assistant: Control Smart Gadgets Without Siri, Alexa, or Google</a> </li> <li class="clearfix"> <span class="timestamp">4 hrs ago</span> <a href="/mobile/news/samsung-galaxy-a34-5g-with-dimensity-1080-spotted-on-geekbench-084003.html" data-uparam="ref_medium=Desktop&ref_source=GB-EN&ref_campaign=Left_Include" class="col-block oiHyperLink"> <picture> <source srcset="https://images.gizbot.com/webp/fit-in/img/157x88/2022/11/samsung-galaxy-a34--1669359224.jpg"> <source srcset="https://images.gizbot.com/png/fit-in/img/157x88/2022/11/samsung-galaxy-a34--1669359224.jpg"> <img src="https://images.gizbot.com/fit-in/img/157x88/2022/11/samsung-galaxy-a34--1669359224.jpg" alt="Samsung Galaxy A34 5G With Dimensity 1080 Spotted On Geekbench " class="lazy"/> </picture> </a> <a href="/mobile/news/samsung-galaxy-a34-5g-with-dimensity-1080-spotted-on-geekbench-084003.html" data-uparam="ref_medium=Desktop&ref_source=GB-EN&ref_campaign=Left_Include" class="os-short-text oiHyperLink">Samsung Galaxy A34 5G With Dimensity 1080 Spotted On Geekbench </a> </li> <li class="clearfix"> <span class="timestamp">5 hrs ago</span> <a href="/internet/news/martian-dust-wont-bury-perseverance-rover-rock-samples-084002.html" data-uparam="ref_medium=Desktop&ref_source=GB-EN&ref_campaign=Left_Include" class="col-block oiHyperLink"> <picture> <source srcset="https://images.gizbot.com/webp/fit-in/img/157x88/2022/12/pic2-1672290915.jpg"> <source srcset="https://images.gizbot.com/png/fit-in/img/157x88/2022/12/pic2-1672290915.jpg"> <img src="https://images.gizbot.com/fit-in/img/157x88/2022/12/pic2-1672290915.jpg" alt="Martian Dust Won’t Bury Perseverance Rover’s Rock Samples" class="lazy"/> </picture> </a> <a href="/internet/news/martian-dust-wont-bury-perseverance-rover-rock-samples-084002.html" data-uparam="ref_medium=Desktop&ref_source=GB-EN&ref_campaign=Left_Include" class="os-short-text oiHyperLink">Martian Dust Won’t Bury Perseverance Rover’s Rock Samples</a> </li> </ul> </div> <div id="div-gpt-ad-1575886695307-0"></div> <div id="article-video-block-new"> <div class="oi-left-heading"><a href="/videos/" target="_blank">Must Watch <i class="video-play-icon"></i></a></div> </div> <div class="oi-related bd-related-videos"> <h2 class="oi-left-heading">Don't Miss <i class="exclamation-icon" style="height: 20px;"></i></h2> <ul id="verticleLinks"> <li class="clearfix"> <a href="https://www.goodreturns.in"><span class="timestamp">Finance</span></a> <a href="https://www.goodreturns.in/news/fm-sitharaman-discharged-from-aiims-1270966.html?utm_medium=Desktop&utm_source=GB-EN&utm_campaign=Left_Include" class="col-block"><img alt="FM Sitharaman Discharged, From AIIMS" data-pagespeed-lazy-src="https://www.goodreturns.in/img/150x99/2021/01/nirmalasitharaman-1589628214-1611918513.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="https://www.goodreturns.in/news/fm-sitharaman-discharged-from-aiims-1270966.html?utm_medium=Desktop&utm_source=GB-EN&utm_campaign=Left_Include" class="os-short-text">FM Sitharaman Discharged, From AIIMS</a> </li> <li class="clearfix"> <a href="https://www.boldsky.com"><span class="timestamp">Lifestyle</span></a> <a href="https://www.boldsky.com/health/wellness/new-year-2023-tips-for-making-new-years-resolutions-that-last-143744.html?utm_medium=Desktop&utm_source=GB-EN&utm_campaign=Left_Include" class="col-block"><img alt="New Year 2023: Tips For Making New Year's Resolutions That Last" data-pagespeed-lazy-src="https://www.boldsky.com/img/150x99/2022/12/tipsformakingnewyearresolutionsthatlast-1672306155.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="https://www.boldsky.com/health/wellness/new-year-2023-tips-for-making-new-years-resolutions-that-last-143744.html?utm_medium=Desktop&utm_source=GB-EN&utm_campaign=Left_Include" class="os-short-text">New Year 2023: Tips For Making New Year's Resolutions That Last</a> </li> <li class="clearfix"> <a href="https://www.filmibeat.com"><span class="timestamp">Movies</span></a> <a href="https://www.filmibeat.com/telugu/news/2022/this-is-why-kannadigas-hate-rashmika-actress-gets-trolled-for-stereotyping-south-cinema-songs-345097.html?utm_medium=Desktop&utm_source=GB-EN&utm_campaign=Left_Include" class="col-block"><img alt="" This Is Why We Do Not Entertain This Actress": Rashmika Mandanna Gets Trolled Brutally, Know Why!" data-pagespeed-lazy-src="https://www.filmibeat.com/img/150x99/2022/12/rash2-1672305487.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="https://www.filmibeat.com/telugu/news/2022/this-is-why-kannadigas-hate-rashmika-actress-gets-trolled-for-stereotyping-south-cinema-songs-345097.html?utm_medium=Desktop&utm_source=GB-EN&utm_campaign=Left_Include" class="os-short-text">"This Is Why We Do Not Entertain This Actress": Rashmika Mandanna Gets Trolled Brutally, Know Why!</a> </li> <li class="clearfix"> <a href="https://www.oneindia.com"><span class="timestamp">News</span></a> <a href="https://www.oneindia.com/india/3-pfi-leaders-go-missing-before-nia-raid-in-kerala-did-local-police-leak-information-3505283.html?utm_medium=Desktop&utm_source=GB-EN&utm_campaign=Left_Include" class="col-block"><img alt="3 PFI leaders go missing before NIA raid in Kerala: Did local police leak information?" data-pagespeed-lazy-src="https://www.oneindia.com/img/150x99/2022/10/nia-pfi-1667015794.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="https://www.oneindia.com/india/3-pfi-leaders-go-missing-before-nia-raid-in-kerala-did-local-police-leak-information-3505283.html?utm_medium=Desktop&utm_source=GB-EN&utm_campaign=Left_Include" class="os-short-text">3 PFI leaders go missing before NIA raid in Kerala: Did local police leak information?</a> </li> <li class="clearfix"> <a href="https://www.mykhel.com"><span class="timestamp">Sports</span></a> <a href="https://www.mykhel.com/cricket/cameron-green-set-to-undergo-surgery-mitchell-starc-could-miss-opening-test-against-india-205378.html?utm_medium=Desktop&utm_source=GB-EN&utm_campaign=Left_Include" class="col-block"><img alt="Cameron Green set to undergo surgery, Mitchell Starc could miss opening Test against India" data-pagespeed-lazy-src="https://www.mykhel.com/img/150x99/2022/12/starc-green-australia-celebration-1672304280.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="https://www.mykhel.com/cricket/cameron-green-set-to-undergo-surgery-mitchell-starc-could-miss-opening-test-against-india-205378.html?utm_medium=Desktop&utm_source=GB-EN&utm_campaign=Left_Include" class="os-short-text">Cameron Green set to undergo surgery, Mitchell Starc could miss opening Test against India</a> </li> <li class="clearfix"> <a href="https://www.drivespark.com"><span class="timestamp">Automobiles</span></a> <a href="https://www.drivespark.com/four-wheelers/2022/toyota-innova-hycross-5-variants-which-one-to-choose-037264.html?utm_medium=Desktop&utm_source=GB-EN&utm_campaign=Left_Include" class="col-block"><img alt="Toyota Innova Hycross – 5 Variants, But Which One To Choose?" data-pagespeed-lazy-src="https://www.drivespark.com/img/150x99/2022/12/toyota-innova-hycross-exterior-1672300532.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="https://www.drivespark.com/four-wheelers/2022/toyota-innova-hycross-5-variants-which-one-to-choose-037264.html?utm_medium=Desktop&utm_source=GB-EN&utm_campaign=Left_Include" class="os-short-text">Toyota Innova Hycross – 5 Variants, But Which One To Choose?</a> </li> <li class="clearfix"> <a href="https://www.careerindia.com"><span class="timestamp">Education</span></a> <a href="https://www.careerindia.com/news/admissions/neet-counselling-2022-mcc-issues-advisory-for-ug-pg-ss-candidates-034026.html?utm_medium=Desktop&utm_source=GB-EN&utm_campaign=Left_Include" class="col-block"><img alt="NEET Counselling 2022: MCC issues advisory for UG, PG, SS Candidates " data-pagespeed-lazy-src="https://www.careerindia.com/img/150x99/2022/04/neet-1649061723.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="https://www.careerindia.com/news/admissions/neet-counselling-2022-mcc-issues-advisory-for-ug-pg-ss-candidates-034026.html?utm_medium=Desktop&utm_source=GB-EN&utm_campaign=Left_Include" class="os-short-text">NEET Counselling 2022: MCC issues advisory for UG, PG, SS Candidates </a> </li> <li class="clearfix"> <a href="https://www.nativeplanet.com"><span class="timestamp">Travel</span></a> <a href="https://www.nativeplanet.com/travel-guide/what-is-amrit-bharat-station-scheme-for-indian-railways-all-you-need-to-know-007578.html?utm_medium=Desktop&utm_source=GB-EN&utm_campaign=Left_Include" class="col-block"><img alt="What Is Amrit Bharat Station Scheme For Indian Railways? All You Need To Know" data-pagespeed-lazy-src="https://www.nativeplanet.com/img/150x99/2022/12/railway-1555348-1920-1672242083.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></a> <a href="https://www.nativeplanet.com/travel-guide/what-is-amrit-bharat-station-scheme-for-indian-railways-all-you-need-to-know-007578.html?utm_medium=Desktop&utm_source=GB-EN&utm_campaign=Left_Include" class="os-short-text">What Is Amrit Bharat Station Scheme For Indian Railways? All You Need To Know</a> </li> </ul> <ul id="bottomLeftVideo"></ul> </div></div> <div class="oi-article-rt"> <nav> <div class="breadcrump clearfix" data-category="News" id="article-breadcrumb"> <div> <a href="/"><span>Home</span></a></div> <span class="breadcrumb-nav">&nbsp; <img data-pagespeed-lazy-src="/images/green.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"> &nbsp;</span> <div> <a href="/social-media/"> <span>Social media</span> </a> </div> <span class="breadcrumb-nav">&nbsp; <img data-pagespeed-lazy-src="/images/green.jpg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"> &nbsp;</span> <div> <a href="/social-media/news/"> <span>News</span> </a> </div> </div> </nav> <div class="headline"> <h1 class="articleheading">Elon Musk Hints Twitter Outage Due To Backend Upgrades, Assures Faster Performance</h1> <div class="io-category" style="display: none">News</div> <div class="io-author" style="display: none">oi
-Alap Naik Desai</div> </div> <div class="author-detail clearfix"> <div data-author="Alap Naik Desai" class="dateTime"> <div class="author-profile written-by">By <a rel="author" href="/authors/alapnaikdesai.html" title="Profile of Alap Naik Desai" target="_blank"><strong>Alap Naik Desai</strong></a></div> </div> <div class="time-date"> <span>|
<time datetime="2022-12-29T15:56:11+05:30" itemprop="datePublished">
Published: Thursday, December 29, 2022, 15:56 [IST]
</time> </span> </div> </div> <div class="google-ad google-text-ad"> <div class="vuukle-powerbar"></div> <div class="article-amazon-ad" id="amazon_top_block" style="display: none;"></div> </div> <div id="toptextpromo"></div><div class="clearfix"></div><div class="big_center_img" data-cl-cnt="0" data-cnt-t="0" data-gal-src="https://images.gizbot.com/fit-in/img/600x388/2022/12/elon-musk-twitter-server-upgrade-1672309194.jpg"><figure><picture><source srcset="https://images.gizbot.com/webp/fit-in/img/600x388/2022/12/elon-musk-twitter-server-upgrade-1672309194.jpg"><source srcset="https://images.gizbot.com/png/fit-in/img/600x388/2022/12/elon-musk-twitter-server-upgrade-1672309194.jpg"><img data-pagespeed-lazy-src="https://images.gizbot.com/fit-in/img/600x388/2022/12/elon-musk-twitter-server-upgrade-1672309194.jpg" vspace="5" id="preview-img" hspace="5" class="image_listical" style="border:0px" alt="Elon Musk Hints Twitter Outage Due To Backend Upgrades" title="Elon Musk Hints Twitter Outage Due To Backend Upgrades" data-cl-slideshow="" data-cl-title="Elon Musk Hints Twitter Outage Due To Backend Upgrades" data-cl-description="" data-cl-imageid="84006-0" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/></picture></figure></div><p>Twitter had gone down for a few hours yesterday, leaving many users fuming. Around 10,000 people reported issues with the social media platform. Twitter started functioning normally after about two hours. Twitter CEO Elon Musk has now indicated the micro-blogging platform was undergoing maintenance and upgrades. Musk has assured that the Twitter apps should feel a little faster.</p><div class="promote_oi_articles"></div><div id="deeplink_1" class="dynamic-deeplink" style="display-none"></div><div class='cmscontent-article1 inhouse-content' id='cmscontent-article1' data-zoneId='{"backfill":"83","inhouse":"79"}' data-reviveId='{"backfill":"9de4f035bc8106094a8824fc0cfb6de3","inhouse":"9de4f035bc8106094a8824fc0cfb6de3"}'>&nbsp;<div class='refreshInarticleAd listical-ad-left inarticlead' data-slno='0' data-refreshed='1' data-status='false' data-adval=0 style='display:block;'><div id='div-gpt-ad-1469421140524-0' class='oi-axt' data-elementid='4'></div></div></div><h2>Twitter Sputters Back to Life After "Server Upgrades"?</h2><p>Twitter suffered its first-ever major outage after Elon Musk acquired the platform in late October this year. Several thousand users claimed they experienced problems with the site on Wednesday at 7:30 AM EST (6:30 PM IST).</p><div id="taboola-mid-article-thumbnails"></div><p><center><iframe style="border:0 none;margin: 0 auto;width:315px;height:415px; clear: both;" scrolling="no" src="https://polls.oneindia.com/iframe-poll/gizbot-smartphone-awards-poll.html"></iframe></center></p><p>DownDetector, a website that tracks site internet traffic and problems tweeted, "User reports indicate Twitter has been having problems since 7:13 EST." However, Musk claimed Twitter was working for him by tweeting, "works for me", even while users were reporting that they were facing problems accessing the platform.</p><div id="deeplink_2" class="dynamic-deeplink" style="display-none"></div><p><div class="clearfix"></div><blockquote class="twitter-tweet blockquote"><p lang="en" dir="ltr">Works for me</p>&mdash; Elon Musk (@elonmusk) <a href="https://twitter.com/elonmusk/status/1608273870901096454?ref_src=twsrc%5Etfw" rel="nofollow">December 29, 2022</a></blockquote> <script type="text/javascript" data-pagespeed-no-defer>pagespeed.lazyLoadImages.overrideAttributeFunctions();</script><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><p>Elon Musk has now indirectly admitted that Twitter was facing some issues in the backend by tweeting the platform was undergoing an upgrade. The Tesla CEO wrote, "Significant backend server architecture changes rolled out."</p><p><div class="clearfix"></div><blockquote class="twitter-tweet blockquote"><p lang="en" dir="ltr">Significant backend server architecture changes rolled out. Twitter should feel faster.</p>&mdash; Elon Musk (@elonmusk) <a href="https://twitter.com/elonmusk/status/1608324539779551232?ref_src=twsrc%5Etfw" rel="nofollow">December 29, 2022</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><div id="deeplink_3" class="dynamic-deeplink" style="display-none"></div><h2>Twitter Should "Feel Faster" Claims Musk</h2><p>Elon Musk has assured that the upgrades should improve Twitter's performance. While he did not offer any numbers, Musk claimed, "Twitter should feel faster".</p><p>When Twitter users were facing issues logging in or posting tweets, the platform's error message read:</p><blockquote><p>"Something went wrong, but don't fret -- it's not your fault. Let's try again."</p><div id='div-gpt-ad-1542196213862-0' class='viroolVideo oi-axt'></div></blockquote><p>Twitter faced a <a href="https://www.gizbot.com/social-media/news/twitter-down-in-several-locations-including-india-083389.html" target="_blank">similar outage just a few days after Elon Musk had acquired the platform</a>. However, back then, only Twitter's desktop or web version failed to work reliably for a few hours. The iOS and Android apps were working normally. Wednesday's outage impacted both the Twitter mobile apps and the desktop or web version.</p><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script><style type="text/css">.blockquote { display: none; }</style><div id="endofcontent"></div><div id="bottomPromo"></div><div class="comments-wrap">
<span id="text_change"><a class="vuuk_num" id="vuuk_num" data="vuukle-count" href="#vuukle-comments" aria-label="Vuukle"></a><a href="#vuukle-comments"> Comments </a><i class="comments-icon"></i></span></a>
</div>
<div id="oneliner-promo"></div> <div class="slider-article-list-wrap"> <div class="slider-widget-next widgetHeading"><a href="/topic/Twitter/"><strong>More TWITTER News</strong></a></div> <div class="slider-article-lists clearfix"> <ul> <li> <div class="slider-article-thumbimg"> <a href="/social-media/features/twitter-impressions-count-tweet-views-platform-growing-musk-083946.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider"> <picture><source srcset="https://images.gizbot.com/webp/fit-in/img/157x88/2022/12/elon-musk-twitter-tweet-view-count-1671790797.jpg"><source srcset="https://images.gizbot.com/png/fit-in/img/157x88/2022/12/elon-musk-twitter-tweet-view-count-1671790797.jpg"><img src="https://images.gizbot.com/fit-in/img/157x88/2022/12/elon-musk-twitter-tweet-view-count-1671790797.jpg" alt="Twitter To Reveal “Impressions” Count: Tweet “Views” Shows Platform Growing, Claims Musk"/><picture> </a> </div> <div class="slider-article-title"><a href="/social-media/features/twitter-impressions-count-tweet-views-platform-growing-musk-083946.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider">Twitter To Reveal “Impressions” Count: Tweet “Views” Shows Platform Growing, Claims Musk</a> </div> </li> <li> <div class="slider-article-thumbimg"> <a href="/social-media/news/elon-musk-poll-quit-twitter-ceo-how-users-responded-083914.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider"> <picture><source srcset="https://images.gizbot.com/webp/fit-in/img/157x88/2022/12/elon-musk-twitter-ceo-resign-poll-1671537952.jpg"><source srcset="https://images.gizbot.com/png/fit-in/img/157x88/2022/12/elon-musk-twitter-ceo-resign-poll-1671537952.jpg"><img src="https://images.gizbot.com/fit-in/img/157x88/2022/12/elon-musk-twitter-ceo-resign-poll-1671537952.jpg" alt="Elon Musk Asked If He Should Quit As Twitter CEO: Here's How Users Responded"/><picture> </a> </div> <div class="slider-article-title"><a href="/social-media/news/elon-musk-poll-quit-twitter-ceo-how-users-responded-083914.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider">Elon Musk Asked If He Should Quit As Twitter CEO: Here's How Users Responded</a> </div> </li> <li> <div class="slider-article-thumbimg"> <a href="/apps/news/twitter-blue-subscription-will-require-mobile-number-verification-083841.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider"> <picture><source srcset="https://images.gizbot.com/webp/fit-in/img/157x88/2022/12/twitterblue-1670914741.jpg"><source srcset="https://images.gizbot.com/png/fit-in/img/157x88/2022/12/twitterblue-1670914741.jpg"><img src="https://images.gizbot.com/fit-in/img/157x88/2022/12/twitterblue-1670914741.jpg" alt="Twitter Blue Subscription Will Require Mobile Number Verification"/><picture> </a> </div> <div class="slider-article-title"><a href="/apps/news/twitter-blue-subscription-will-require-mobile-number-verification-083841.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider">Twitter Blue Subscription Will Require Mobile Number Verification</a> </div> </li> <li> <div class="slider-article-thumbimg"> <a href="/social-media/features/is-twitter-blue-worth-your-money-relaunch-explained-083835.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider"> <picture><source srcset="https://images.gizbot.com/webp/fit-in/img/157x88/2022/12/twitter-blue-relaunch-2-1670910046.jpg"><source srcset="https://images.gizbot.com/png/fit-in/img/157x88/2022/12/twitter-blue-relaunch-2-1670910046.jpg"><img src="https://images.gizbot.com/fit-in/img/157x88/2022/12/twitter-blue-relaunch-2-1670910046.jpg" alt="Is Twitter Blue Worth Your Money? Here's How The Relaunch Changes Things"/><picture> </a> </div> <div class="slider-article-title"><a href="/social-media/features/is-twitter-blue-worth-your-money-relaunch-explained-083835.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider">Is Twitter Blue Worth Your Money? Here's How The Relaunch Changes Things</a> </div> </li> <li> <div class="slider-article-thumbimg"> <a href="/internet/news/twitter-files-2-0-explained-what-is-it-who-was-affected-083815.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider"> <picture><source srcset="https://images.gizbot.com/webp/fit-in/img/157x88/2022/12/elon-musk-1670655075.jpg"><source srcset="https://images.gizbot.com/png/fit-in/img/157x88/2022/12/elon-musk-1670655075.jpg"><img src="https://images.gizbot.com/fit-in/img/157x88/2022/12/elon-musk-1670655075.jpg" alt="Twitter Files 2.0 Explained: What is it? Who was Affected?"/><picture> </a> </div> <div class="slider-article-title"><a href="/internet/news/twitter-files-2-0-explained-what-is-it-who-was-affected-083815.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider">Twitter Files 2.0 Explained: What is it? Who was Affected?</a> </div> </li> <li> <div class="slider-article-thumbimg"> <a href="/social-media/news/twitter-blue-subscription-prices-higher-iphone-users-web-version-apple-tax-083790.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider"> <picture><source srcset="https://images.gizbot.com/webp/fit-in/img/157x88/2022/12/musk-twitter-blue-ios-iphone-apple-1670491627.jpg"><source srcset="https://images.gizbot.com/png/fit-in/img/157x88/2022/12/musk-twitter-blue-ios-iphone-apple-1670491627.jpg"><img src="https://images.gizbot.com/fit-in/img/157x88/2022/12/musk-twitter-blue-ios-iphone-apple-1670491627.jpg" alt="Twitter Blue Subscription Prices May Be Higher For iPhone Users Due To ‘Apple Tax’?"/><picture> </a> </div> <div class="slider-article-title"><a href="/social-media/news/twitter-blue-subscription-prices-higher-iphone-users-web-version-apple-tax-083790.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider">Twitter Blue Subscription Prices May Be Higher For iPhone Users Due To ‘Apple Tax’?</a> </div> </li> <li> <div class="slider-article-thumbimg"> <a href="/internet/news/elon-musk-converts-some-rooms-at-the-twitter-hq-into-bedroom-for-tired-employees-083789.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider"> <picture><source srcset="https://images.gizbot.com/webp/fit-in/img/157x88/2022/12/elonmuskaddsbedroomsattwitterhq-1670489723.jpg"><source srcset="https://images.gizbot.com/png/fit-in/img/157x88/2022/12/elonmuskaddsbedroomsattwitterhq-1670489723.jpg"><img src="https://images.gizbot.com/fit-in/img/157x88/2022/12/elonmuskaddsbedroomsattwitterhq-1670489723.jpg" alt="Elon Musk Converts Some Rooms at the Twitter HQ Into Bedroom For “Tired Employees”"/><picture> </a> </div> <div class="slider-article-title"><a href="/internet/news/elon-musk-converts-some-rooms-at-the-twitter-hq-into-bedroom-for-tired-employees-083789.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider">Elon Musk Converts Some Rooms at the Twitter HQ Into Bedroom For “Tired Employees”</a> </div> </li> <li> <div class="slider-article-thumbimg"> <a href="/miscellaneous/news/elon-musk-fears-assassination-attempts-twitter-files-free-speech-reason-083748.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider"> <picture><source srcset="https://images.gizbot.com/webp/fit-in/img/157x88/2022/12/elon-musk-safety-twitter-1670305241.jpg"><source srcset="https://images.gizbot.com/png/fit-in/img/157x88/2022/12/elon-musk-safety-twitter-1670305241.jpg"><img src="https://images.gizbot.com/fit-in/img/157x88/2022/12/elon-musk-safety-twitter-1670305241.jpg" alt="Elon Musk Fears Assassination Attempts: Are “Twitter Files” Or Free Speech The Reason?"/><picture> </a> </div> <div class="slider-article-title"><a href="/miscellaneous/news/elon-musk-fears-assassination-attempts-twitter-files-free-speech-reason-083748.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider">Elon Musk Fears Assassination Attempts: Are “Twitter Files” Or Free Speech The Reason?</a> </div> </li> <li> <div class="slider-article-thumbimg"> <a href="/social-media/news/twitter-restores-pranay-pathole-suspended-account-did-elon-musk-intervene-083736.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider"> <picture><source srcset="https://images.gizbot.com/webp/fit-in/img/157x88/2022/12/elon-musk-twitter-pranay-pathole-1670063114.jpg"><source srcset="https://images.gizbot.com/png/fit-in/img/157x88/2022/12/elon-musk-twitter-pranay-pathole-1670063114.jpg"><img src="https://images.gizbot.com/fit-in/img/157x88/2022/12/elon-musk-twitter-pranay-pathole-1670063114.jpg" alt="Twitter Restores Pranay Pathole's Account: Did Elon Musk Intervene?"/><picture> </a> </div> <div class="slider-article-title"><a href="/social-media/news/twitter-restores-pranay-pathole-suspended-account-did-elon-musk-intervene-083736.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider">Twitter Restores Pranay Pathole's Account: Did Elon Musk Intervene?</a> </div> </li> <li> <div class="slider-article-thumbimg"> <a href="/social-media/news/elon-musk-expose-twitter-suppressed-hunter-biden-story-083731.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider"> <picture><source srcset="https://images.gizbot.com/webp/fit-in/img/157x88/2022/12/elon-musk-hunter-biden-twitter-files-1670049293.jpg"><source srcset="https://images.gizbot.com/png/fit-in/img/157x88/2022/12/elon-musk-hunter-biden-twitter-files-1670049293.jpg"><img src="https://images.gizbot.com/fit-in/img/157x88/2022/12/elon-musk-hunter-biden-twitter-files-1670049293.jpg" alt="Elon Musk Exposes Twitter’s Alleged Suppression Of “Hunter Biden Story”"/><picture> </a> </div> <div class="slider-article-title"><a href="/social-media/news/elon-musk-expose-twitter-suppressed-hunter-biden-story-083731.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider">Elon Musk Exposes Twitter’s Alleged Suppression Of “Hunter Biden Story”</a> </div> </li> <li> <div class="slider-article-thumbimg"> <a href="/social-media/news/twitter-purge-spam-scam-accounts-how-legitimate-users-protect-their-accounts-083710.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider"> <picture><source srcset="https://images.gizbot.com/webp/fit-in/img/157x88/2022/12/twitter-purge-spam-bots-scam-accounts-1669872644.jpg"><source srcset="https://images.gizbot.com/png/fit-in/img/157x88/2022/12/twitter-purge-spam-bots-scam-accounts-1669872644.jpg"><img src="https://images.gizbot.com/fit-in/img/157x88/2022/12/twitter-purge-spam-bots-scam-accounts-1669872644.jpg" alt="Twitter Starts ‘Purging’ Troublesome Accounts: How Legitimate Users Can Safeguard Theirs?"/><picture> </a> </div> <div class="slider-article-title"><a href="/social-media/news/twitter-purge-spam-scam-accounts-how-legitimate-users-protect-their-accounts-083710.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider">Twitter Starts ‘Purging’ Troublesome Accounts: How Legitimate Users Can Safeguard Theirs?</a> </div> </li> <li> <div class="slider-article-thumbimg"> <a href="/social-media/news/elon-musk-twitter-removal-from-apple-app-store-083695.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider"> <picture><source srcset="https://images.gizbot.com/webp/fit-in/img/157x88/2022/11/elon-musk-1669713812.jpg"><source srcset="https://images.gizbot.com/png/fit-in/img/157x88/2022/11/elon-musk-1669713812.jpg"><img src="https://images.gizbot.com/fit-in/img/157x88/2022/11/elon-musk-1669713812.jpg" alt="Is Apple Withholding Twitter from App Store? Elon Musk Claims So"/><picture> </a> </div> <div class="slider-article-title"><a href="/social-media/news/elon-musk-twitter-removal-from-apple-app-store-083695.html" class="oiHyperLink" data-uparam="ref_medium=Mobile&ref_source=GZ-EN&ref_campaign=Similar-News-Slider">Is Apple Withholding Twitter from App Store? Elon Musk Claims So</a> </div> </li> </ul> </div> </div><div class='youtube_embed_video_list common_widget_div' id='https://www.dailymotion.com/embed/playlist/x6eszl&autoplay=0'></div><center><div data-album-id='' data-host='www.gizbot.com' class='embed_photos_container'></div></center>
<style>
    .gadgetfinder-content .head-text ul {padding: 0; margin: 0;}

.gadgetfinder-content .head-text ul li {float: left;width: 32%;list-style-type: none;}

.gadgetfinder-content .head-text ul li a {
    display: block;
    background: #fff;
    color: #c6c6c6;
    text-decoration: none;
    font-size: 16px;
    text-align: center;
    padding: 10px;
    margin: 0;font-weight: bold;
    text-transform: uppercase;
}

.gadgetfinder-content .head-text ul li a.selected {color: #fff;background: #629c49;}

.gadgetfinder-editorspick ul {padding: 0;margin: 0;}

.gadgetfinder-editorspick ul li {text-align: center;list-style-type: none;}

.gadgetfinder-editorspick ul li {
    text-align: center;
    list-style-type: none;
    box-shadow: 1px 1px 5px #dedede;
    border-radius: 5px;
    border: 1px solid #f3f3f3;
}

.home-mobile-thumbimg {padding: 5px;}

.home-mobile-heading {
    font-size: 16px;
    color: #000;
    font-weight: bold;
}

.home-mobile-heading  a {
    color: #000;
    display: block;
    text-decoration: none;
}

.home-mobile-price {
    color: #4c4c4c;
    font-size: 18px;
    font-weight: bold;
}

.gadgetfinder-editorspick {padding: 15px;position: relative;}

.gadgetfinder-content .head-text:after {content: '';clear: both;display: table;}


.gadgetfinder-editorspick .bx-wrapper .bx-controls a::before {
    content: "";
    position: absolute;
    top: 0;
    bottom: 0;
    left: 0;
    right: 0;
    margin: auto;
    width: 12px;
    height: 12px;
    border-left: solid 2px #404040;
    border-bottom: solid 2px #404040;
}

.gadgetfinder-editorspick .bx-wrapper .bx-controls a.bx-prev::before {
    -moz-transform: rotate(45deg);
    -ms-transform: rotate(45deg);
    -webkit-transform: rotate(45deg);
    transform: rotate(45deg);
}

.gadgetfinder-editorspick .bx-wrapper .bx-controls a.bx-next::before {
    -moz-transform: rotate(-135deg);
    -ms-transform: rotate(-135deg);
    -webkit-transform: rotate(-135deg);
    transform: rotate(-135deg);
}

.gadgetfinder-editorspick .bx-wrapper .bx-controls  a {
    position: absolute;
    width: 30px;
    height: 30px;
    top: 0;
    bottom: 85px;
    margin: auto;
    text-indent: -9999px;
}

.gadgetfinder-editorspick .bx-wrapper .bx-controls a.bx-prev {
    left: 0;
}

.gadgetfinder-editorspick .bx-wrapper .bx-controls a.bx-next {
    right: 0;
}

.gadgetfinder-editorspick .bx-wrapper .bx-viewport{
    width: 108% !important;
}

.gadgetfinder-editorspick .bx-wrapper img  {
    display: inherit;
    max-height: 150px;
}
.gadgetfinder-editorspick .home-mobile-heading{
    font-weight: 600;
}
.gadgetfinder-editorspick .home-mobile-price{
    font-weight: 600;
    font-size: 15px;
}
.gadgetfinder-content .head-text{
    border-bottom: none;
    background: none;
}

.gadgetfinder-editorspick ul li{
    height: 240px;
}

.best-mobiles{
    color: #eb1703;
    font-weight: bold;
    padding: 10px;
    font-size: 18px;
    clear:both;
}
</style>
<div class='best-mobiles'>Best Mobiles in India</div>
<div class="gadgetfinder-content" id="best-block">
<div class="head-text top-sec" id="best_category">
<ul>
<li><a href="#best-cameras" onclick="javascript:void(0)">Best Cameras</a></li>
<li><a href="#best-selling" onclick="javascript:void(0)">Best Selling</a></li>
<li><a href="#upcoming" onclick="javascript:void(0)">Upcoming</a></li>
</ul>
</div>
<div class="gadgetfinder-editorspick gadgetfinder-editorspick_mobiles" id="best-cameras">
<ul class="slider1">
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/samsung-galaxy-s21-fe-5g-8554/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2022/01/samsung-galaxy-s21-fe_1641274949.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2022/01/samsung-galaxy-s21-fe_1641274949.png">
<img alt="Samsung Galaxy S21 FE 5G" title="Samsung Galaxy S21 FE 5G" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2022/01/samsung-galaxy-s21-fe_1641274949.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/samsung-galaxy-s21-fe-5g-8554/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Samsung Galaxy S21 FE 5G</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>54,999</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/oppo-reno7-pro-5g-8944/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2022/02/oppo-reno7-pro-5g_1643971763.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2022/02/oppo-reno7-pro-5g_1643971763.png">
<img alt="OPPO Reno7 Pro 5G" title="OPPO Reno7 Pro 5G" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2022/02/oppo-reno7-pro-5g_1643971763.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/oppo-reno7-pro-5g-8944/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">OPPO Reno7 Pro 5G</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>36,599</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/xiaomi-11t-pro-5g-8857/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2021/09/xiaomi-11t-pro_1631774562.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2021/09/xiaomi-11t-pro_1631774562.png">
<img alt="Xiaomi 11T Pro 5G" title="Xiaomi 11T Pro 5G" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2021/09/xiaomi-11t-pro_1631774562.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/xiaomi-11t-pro-5g-8857/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Xiaomi 11T Pro 5G</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>39,999</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/vivo-v23-pro-5g-9019/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2022/01/vivo-v23-pro-5g_1641392402.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2022/01/vivo-v23-pro-5g_1641392402.png">
<img alt="Vivo V23 Pro 5G" title="Vivo V23 Pro 5G" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2022/01/vivo-v23-pro-5g_1641392402.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/vivo-v23-pro-5g-9019/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Vivo V23 Pro 5G</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>38,990</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/apple-iphone-13-pro-max-8492/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2021/09/apple-iphone-13-pro-max_1631685134.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2021/09/apple-iphone-13-pro-max_1631685134.png">
<img alt="Apple iPhone 13 Pro Max" title="Apple iPhone 13 Pro Max" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2021/09/apple-iphone-13-pro-max_1631685134.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/apple-iphone-13-pro-max-8492/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Apple iPhone 13 Pro Max</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>1,29,900</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/vivo-x70-pro-plus-8544/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2021/09/vivo-x70-pro-plus_1630909444.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2021/09/vivo-x70-pro-plus_1630909444.png">
<img alt="Vivo X70 Pro Plus" title="Vivo X70 Pro Plus" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2021/09/vivo-x70-pro-plus_1630909444.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/vivo-x70-pro-plus-8544/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Vivo X70 Pro Plus</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>79,990</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/oppo-reno6-pro-5g-8623/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2021/07/oppo-reno6-pro-5g_1626262045.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2021/07/oppo-reno6-pro-5g_1626262045.png">
<img alt="OPPO Reno6 Pro 5G" title="OPPO Reno6 Pro 5G" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2021/07/oppo-reno6-pro-5g_1626262045.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/oppo-reno6-pro-5g-8623/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">OPPO Reno6 Pro 5G</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>38,900</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/redmi-note-10-pro-max-8454/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2021/03/-redmi-note-10-pro-max_1614845220.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2021/03/-redmi-note-10-pro-max_1614845220.png">
<img alt="Redmi Note 10 Pro Max" title="Redmi Note 10 Pro Max" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2021/03/-redmi-note-10-pro-max_1614845220.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/redmi-note-10-pro-max-8454/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Redmi Note 10 Pro Max</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>18,999</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/motorola-moto-g60-8499/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2021/04/motorola-moto-g60_1618226662.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2021/04/motorola-moto-g60_1618226662.png">
<img alt="Motorola Moto G60" title="Motorola Moto G60" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2021/04/motorola-moto-g60_1618226662.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/motorola-moto-g60-8499/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Motorola Moto G60</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>19,300</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/xiaomi-mi-11-ultra-8420/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2021/03/xiaomi-mi-11-ultra_1617178851.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2021/03/xiaomi-mi-11-ultra_1617178851.png">
<img alt="Xiaomi Mi 11 Ultra" title="Xiaomi Mi 11 Ultra" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2021/03/xiaomi-mi-11-ultra_1617178851.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/xiaomi-mi-11-ultra-8420/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Xiaomi Mi 11 Ultra</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>69,999</div>
</li>
</ul>
</div>
<div class="gadgetfinder-editorspick gadgetfinder-editorspick_mobiles" id="best-selling">
<ul class="slider1">
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/apple-iphone-13-8491/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2021/09/apple-iphone-13_1631646990.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2021/09/apple-iphone-13_1631646990.png">
<img alt="Apple iPhone 13" title="Apple iPhone 13" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2021/09/apple-iphone-13_1631646990.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/apple-iphone-13-8491/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Apple iPhone 13</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>79,900</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/samsung-galaxy-s22-ultra-9031/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2022/02/samsung-galaxy-s22-ultra_1644567549.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2022/02/samsung-galaxy-s22-ultra_1644567549.png">
<img alt="Samsung Galaxy S22 Ultra" title="Samsung Galaxy S22 Ultra" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2022/02/samsung-galaxy-s22-ultra_1644567549.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/samsung-galaxy-s22-ultra-9031/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Samsung Galaxy S22 Ultra</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>1,09,999</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/apple-iphone-13-pro-8494/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2021/09/apple-iphone-13-pro_1631684795.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2021/09/apple-iphone-13-pro_1631684795.png">
<img alt="Apple iPhone 13 Pro" title="Apple iPhone 13 Pro" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2021/09/apple-iphone-13-pro_1631684795.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/apple-iphone-13-pro-8494/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Apple iPhone 13 Pro</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>1,19,900</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/samsung-galaxy-a32-8439/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2021/03/samsung-galaxy-a32_1614673996.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2021/03/samsung-galaxy-a32_1614673996.png">
<img alt="Samsung Galaxy A32" title="Samsung Galaxy A32" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2021/03/samsung-galaxy-a32_1614673996.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/samsung-galaxy-a32-8439/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Samsung Galaxy A32</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>21,999</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/apple-iphone-13-pro-max-8492/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2021/09/apple-iphone-13-pro-max_1631685134.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2021/09/apple-iphone-13-pro-max_1631685134.png">
<img alt="Apple iPhone 13 Pro Max" title="Apple iPhone 13 Pro Max" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2021/09/apple-iphone-13-pro-max_1631685134.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/apple-iphone-13-pro-max-8492/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Apple iPhone 13 Pro Max</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>1,29,900</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/samsung-galaxy-a12-8143/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2020/11/samsung-galaxy-a12_1606291959.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2020/11/samsung-galaxy-a12_1606291959.png">
<img alt="Samsung Galaxy A12" title="Samsung Galaxy A12" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2020/11/samsung-galaxy-a12_1606291959.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/samsung-galaxy-a12-8143/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Samsung Galaxy A12</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>12,999</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/oneplus-9-8429/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2021/03/oneplus-9_1616561541.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2021/03/oneplus-9_1616561541.png">
<img alt="OnePlus 9" title="OnePlus 9" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2021/03/oneplus-9_1616561541.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/oneplus-9-8429/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">OnePlus 9</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>44,999</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/redmi-note-10-pro-8453/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2021/03/redmi-note-10-pro_1614845285.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2021/03/redmi-note-10-pro_1614845285.png">
<img alt="Redmi Note 10 Pro" title="Redmi Note 10 Pro" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2021/03/redmi-note-10-pro_1614845285.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/redmi-note-10-pro-8453/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Redmi Note 10 Pro</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>15,999</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/redmi-9a-7770/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2020/09/redmi-9a_1599819182.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2020/09/redmi-9a_1599819182.png">
<img alt="Redmi 9A" title="Redmi 9A" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2020/09/redmi-9a_1599819182.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/redmi-9a-7770/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Redmi 9A</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>7,332</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/vivo-s1-pro-7269/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2020/08/vivo-s1-pro_1597222661.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2020/08/vivo-s1-pro_1597222661.png">
<img alt="Vivo S1 Pro" title="Vivo S1 Pro" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2020/08/vivo-s1-pro_1597222661.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/vivo-s1-pro-7269/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Vivo S1 Pro</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>17,091</div>
</li>
</ul>
</div>
<div class="gadgetfinder-editorspick gadgetfinder-editorspick_mobiles" id="upcoming">
<ul class="slider1">
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/oppo-f21s-pro-9493/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2022/09/oppo-f21s-pro_1662720039.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2022/09/oppo-f21s-pro_1662720039.png">
<img alt="OPPO F21s Pro" title="OPPO F21s Pro" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2022/09/oppo-f21s-pro_1662720039.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/oppo-f21s-pro-9493/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">OPPO F21s Pro</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>
29,999
</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/realme-c30s-9492/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2022/09/realme-c30s_1662718889.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2022/09/realme-c30s_1662718889.png">
<img alt="Realme C30s" title="Realme C30s" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2022/09/realme-c30s_1662718889.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/realme-c30s-9492/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Realme C30s</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>
7,999
</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/realme-narzo-50i-prime-9491/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2022/09/realme-narzo-50i-prime_1662717296.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2022/09/realme-narzo-50i-prime_1662717296.png">
<img alt="Realme Narzo 50i Prime" title="Realme Narzo 50i Prime" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2022/09/realme-narzo-50i-prime_1662717296.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/realme-narzo-50i-prime-9491/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Realme Narzo 50i Prime</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>
8,999
</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/huawei-mate-50e-9489/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2022/09/huawei-mate-50e_1662710642.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2022/09/huawei-mate-50e_1662710642.png">
<img alt="Huawei Mate 50E" title="Huawei Mate 50E" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2022/09/huawei-mate-50e_1662710642.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/huawei-mate-50e-9489/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Huawei Mate 50E</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>
45,835
</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/huawei-mate-50-pro-9487/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2022/09/huawei-mate-50-pro_1662710278.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2022/09/huawei-mate-50-pro_1662710278.png">
<img alt="Huawei Mate 50 Pro" title="Huawei Mate 50 Pro" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2022/09/huawei-mate-50-pro_1662710278.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/huawei-mate-50-pro-9487/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Huawei Mate 50 Pro</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>
77,935
</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/motorola-edge-30-fusion-9485/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2022/09/motorola-edge-30-fusion_1662702019.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2022/09/motorola-edge-30-fusion_1662702019.png">
<img alt="Motorola Edge 30 Fusion" title="Motorola Edge 30 Fusion" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2022/09/motorola-edge-30-fusion_1662702019.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/motorola-edge-30-fusion-9485/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Motorola Edge 30 Fusion</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>
48,030
</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/motorola-edge-30-neo-9484/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2022/09/motorola-edge-30-neo_1662629220.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2022/09/motorola-edge-30-neo_1662629220.png">
<img alt="Motorola Edge 30 Neo" title="Motorola Edge 30 Neo" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2022/09/motorola-edge-30-neo_1662629220.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/motorola-edge-30-neo-9484/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Motorola Edge 30 Neo</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>
29,616
</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/huawei-mate-50-9475/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2022/09/huawei-mate-50_1662553086.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2022/09/huawei-mate-50_1662553086.png">
<img alt="Huawei Mate 50" title="Huawei Mate 50" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2022/09/huawei-mate-50_1662553086.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/huawei-mate-50-9475/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Huawei Mate 50</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>
57,999
</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/vivo-y22-9468/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2022/09/vivo-y22_1662538965.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2022/09/vivo-y22_1662538965.png">
<img alt="Vivo Y22" title="Vivo Y22" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2022/09/vivo-y22_1662538965.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/vivo-y22-9468/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Vivo Y22</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>
12,670
</div>
</li>
<li>
<div class="home-mobile-thumbimg"><a href="https://www.gizbot.com/new-mobiles/sony-xperia-5-iv-9460/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">
<figure>
<picture>
<source srcset="https://images.gizbot.com/webp/fit-in/85x165/img/gadget-finder/original/2022/09/sony-xperia-5-iv_1662098520.png">
<source srcset="https://images.gizbot.com/png/fit-in/85x165/img/gadget-finder/original/2022/09/sony-xperia-5-iv_1662098520.png">
<img alt="Sony Xperia 5 IV" title="Sony Xperia 5 IV" src="https://images.gizbot.com/fit-in/85x165/img/gadget-finder/original/2022/09/sony-xperia-5-iv_1662098520.png">
</picture>
</figure>
</a></div>
<div class="home-mobile-heading"><a href="https://www.gizbot.com/new-mobiles/sony-xperia-5-iv-9460/?ref_source=articlepage&ref_medium=dsktp&ref_campaign=BestMob">Sony Xperia 5 IV</a></div>
<div class="home-mobile-price"><i class="fa fa-rupee"></i>
79,470
</div>
</li>
</ul>
</div>
</div>
<style type="text/css">
	.notifications-block {width: 300px;padding: 30px 0;margin: 0 auto;}
.allow-notifications {
    font-size: 16px;
    height: 45px;
    line-height: 45px;
    padding: 0;
    background: #000;
    color: #ffffff;
    text-transform: uppercase;
    text-align: center;
    padding-right: 50px;
    position: relative;
    cursor: pointer;
    display: none;
}
.allow-notifications i {position: absolute;right: 5px;    top: 5px;width: 35px;height: 35px;color: #000;font-size: 32px;}
.already-subscribed {
    font-size: 14px;
    height: 45px;
    line-height: 45px;
    padding: 0;
    background: #1b74e9;
    color: #ffffff;
    text-align: center;
    padding-right: 50px;
    position: relative;
    display: none;
}
.notification-settings-link {font-size: 14px;color: #0066cc;padding: 30px 0 0 0;font-weight: 600;text-align: center;display: none;}
.notification-settings-link a {color: #0066cc;}
.notification-settings-link a i {vertical-align: middle;}
.already-subscribed i {position: absolute;right: 5px;    top: 5px;width: 35px;height: 35px;color: #000;font-size: 32px;}
.notf-sub .already-subscribed, .notf-sub .notification-settings-link {display: block;}
.notf-sub .allow-notifications {display: none;}
.bell-icons {
    width: 40px;
    height: 36px;
    background: #fff url(/images/bell-icon.svg) no-repeat center;
    background-size: 60%;
    display: block;
    position: absolute;
    right: 2px;
    top: 2px;
}
.tick-icons {
    width: 40px;
    height: 36px;
    background: #fff url(/images/tick-icon.png) no-repeat center;
    background-size: 60%;
    display: block;
    position: absolute;
    right: 2px;
    top: 2px;
}
.notification-outerblock {
	background: #f2f2f2;
    padding: 10px;
    margin: 10px auto;
    float: left;
    width: 600px;
    box-sizing: border-box;
}
.breaking-newstext {font-size: 14px;text-align: center;float: left;margin: 0px 10px;width: 240px;}
.notifications-block {padding: 10px;float: left;clear: none;}
</style>
<div class="notification-outerblock clearfix" id="notification-articleblock" style="display: none;">
<div class="breaking-newstext">
To stay updated with latest technology news & gadget reviews, follow GizBot on <a href="https://twitter.com/gizbot" target="_blank">Twitter</a>, <a href="https://www.facebook.com/gizbot.com/" target="_blank">Facebook</a>, <a href="https://www.youtube.com/channel/UChpms81A8ItnbXTHgJzx5pg" target="_blank">YouTube</a> and also subscribe to our notification.
</div>
<div class="notifications-block clearfix">
<div class="allow-notifications" id="allow-notifications">
Allow Notifications <i class="bell-icons"></i>
</div>
<div class="already-subscribed" id="already-subscribed">
You have already subscribed <i class="tick-icons"></i>
</div>
</div>
</div>
</p> <section> <div id="inread"></div> <div class="clearfix" id="tag-container" data-tags="twitter, elon musk, social media, down" data-eng-tags="Twitter, Elon Musk, Social Media, Down"> <div style="clear: both;"></div> <div class="article-read-more tags-head"> <span class="tags_head">Read More About: </span> <a href="/topic/Twitter">Twitter</a> <a href="/topic/elon-musk">elon musk</a> <a href="/topic/social-media">social media</a> <a href="/topic/down">down</a> </div> </div> <div></div> <div class="article-published">
Story first
published: Thursday, December 29, 2022, 15:56 [IST]
</div> <div class="dayindex-link">
Other articles published on <a href="/2022/12/29/">Dec 29, 2022</a> </div> <div class="ventuno-after-img clearfix"> <div id="vtnEditorialPlayer"></div> </div> </section> </div> </div> </article> </div> </div> </section> <section> <div id="oitaboola" style="padding-top:10px;clear:both;width:97%;"> <div id="taboola-below-article-thumbnails"></div> </div> <div id="impulserWidget"></div> </section> <section id="oitaboolacontainer1"> <div class="non-friendly-scatter clearfix"> <div id="vuukle-comments"></div> <div class="cmscontent-bottom inhouse-content" id="cmscontent-bottom" data-zoneid='{"inhouse":79,"backfill":83}' data-reviveid='{"inhouse":"9de4f035bc8106094a8824fc0cfb6de3","backfill":"9de4f035bc8106094a8824fc0cfb6de3"}'> <div id="div-gpt-ad-1506054776114-0" data-exec=0 data-adval=0 data-elementid="6" class="oiad oi-axt" style="padding-bottom:10px;clear:both;"></div> </div> </div> <div id="article_ad"> <style type="text/css">
 .photos-featured-posts {
 	margin: 15px auto;width: 300px;height: 250px;position: relative;background: 
#fff;font-family: Arial, Helvetica, sans-serif;}
 .photos-featured-posts ul {margin: 
0;padding: 0;list-style-type: none;}
 .photos-featured-posts ul li {
 	list-style-type: none!important;
    border-top: 1px solid #dadada;
    padding: 14px 0;
    margin:0;
 }
 .photos-featured-posts ul li:last-child{border-bottom: 0 none;}
 .photos-featured-posts ul li a {
     font-size: 14px;
     color: #333;
 }
 .cinelist-thumbimg {
     float: left;
     width: 60px;
     margin-right: 10px;
 }
 .photos-featured-posts-text {
     font-size: 13px;
     color: #999;
     position: relative;
     text-align: right;
     bottom: 0px;
 }
 .clear {clear: both;}
 .postTitle{
 	font-size: 14px;
 	line-height: 18px;
 	float: right;
 	width: 230px;
 	font-weight: normal;
 	padding: 0;
 	margin: 0;
 }

 </style> <div id="article_page_ad" style="display: none;"> <div class="photos-featured-posts"> <ul> <li> <a href="/smartphone-awards-2022/gizbot-smartphone-awards-best-battery-smartphones-2022-083974.html" target="_blank"> <picture><source srcset="https://images.gizbot.com/webp/img/2022/12/best-battery-smartphones-1672068245.jpg"><source srcset="https://images.gizbot.com/png/img/2022/12/best-battery-smartphones-1672068245.jpg"><img data-oiqimg="https://images.gizbot.com/img/2022/12/best-battery-smartphones-1672068245.jpg" data-pagespeed-lazy-src="https://images.gizbot.com/img/2022/12/best-battery-smartphones-1672068245.jpg" alt="The Best Battery Smartphones of 2022" title="" class="cinelist-thumbimg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/><picture> </a> <h5 class="postTitle"><a href="/smartphone-awards-2022/gizbot-smartphone-awards-best-battery-smartphones-2022-083974.html" target="_blank">The Best Battery Smartphones of 2022</a></h5> <div class="clear"></div> </li> <li> <a href="/mobile/news/redmi-k60-series-design-colour-variants-confirmed-ahead-of-dec-27-launch-083973.html" target="_blank"> <picture><source srcset="https://images.gizbot.com/webp/img/2022/12/redmik60-1672064751.jpg"><source srcset="https://images.gizbot.com/png/img/2022/12/redmik60-1672064751.jpg"><img data-oiqimg="https://images.gizbot.com/img/2022/12/redmik60-1672064751.jpg" data-pagespeed-lazy-src="https://images.gizbot.com/img/2022/12/redmik60-1672064751.jpg" alt="Redmi K60 Series Design, Colour Variants Confirmed Ahead of Dec 27 Launch" title="" class="cinelist-thumbimg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/><picture> </a> <h5 class="postTitle"><a href="/mobile/news/redmi-k60-series-design-colour-variants-confirmed-ahead-of-dec-27-launch-083973.html" target="_blank">Redmi K60 Series Design, Colour Variants Confirmed Ahead of Dec 27 Launch</a></h5> <div class="clear"></div> </li> <li>  <a href="/mobile/features/vivo-s16-pro-vs-vivo-v25-pro-comparison-083972.html" target="_blank"> <picture><source srcset="https://images.gizbot.com/webp/img/2022/12/vivo-s16-pro-vs-vivo-v25-pro-1672058328.jpg"><source srcset="https://images.gizbot.com/png/img/2022/12/vivo-s16-pro-vs-vivo-v25-pro-1672058328.jpg"><img data-oiqimg="https://images.gizbot.com/img/2022/12/vivo-s16-pro-vs-vivo-v25-pro-1672058328.jpg" data-pagespeed-lazy-src="https://images.gizbot.com/img/2022/12/vivo-s16-pro-vs-vivo-v25-pro-1672058328.jpg" alt="Vivo S16 Pro Vs Vivo V25 Pro: Design, Features, Price Compared" title="" class="cinelist-thumbimg" src="/img/loading.gif" onload="pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);" onerror="this.onerror=null;pagespeed.lazyLoadImages.loadIfVisibleAndMaybeBeacon(this);"/><picture> </a> <h5 class="postTitle"><a href="/mobile/features/vivo-s16-pro-vs-vivo-v25-pro-comparison-083972.html" target="_blank">Vivo S16 Pro Vs Vivo V25 Pro: Design, Features, Price Compared</a></h5> <div class="clear"></div> </li> </ul> <div class="photos-featured-posts-text">Featured Posts</div> </div> </div> </div> </section> </div> </article> </div> <div class="grid3"> <div class="theiaStickySidebar"> <div class="right-ad350px250px"> <div class="clear"></div> <div class="cmscontent-right1 inhouse-content" id="cmscontent-right1" data-zoneid='{"inhouse":79,"backfill":83}' data-reviveid='{"inhouse":"9de4f035bc8106094a8824fc0cfb6de3","backfill":"9de4f035bc8106094a8824fc0cfb6de3"}'> <div style="min-height: 250px;"> <div id="ATF_300x250" data-cb-ad-id="gizbot-300x250" class="ad"> <div id='div-gpt-ad-1384320856135-0' data-exec=0 data-adval=0 data-elementid="1" class="oiad1 oi-axt"></div> </div> </div> </div> </div> <div id="gizbot_micro_poll_container" style="padding: 10px 0;"></div> <style>
.maindiv{
	margin:0!important;
}
.heading_div{
	font-size: 14px!important;
}
#article-recommended, #article-editors{
	padding: 5px 0!important;
}
.head-text{
	padding: 0!important;
}
.adg_native_home{
	text-align:left!important;
}
</style> <div id="artRight"></div> <div id="sidebarRight" style="clear:both;"></div> <div class="opinion-poll" style="clear: both; margin-top: 15px;"> <div id="oneindia_polls_container"></div> </div> <div class="cmscontent-right1 clearfix"> <div id="div-gpt-ad-1384320970624-1" data-exec=0 data-adval=0 data-elementid="2" class="oiad oi-axt" style="padding: 12px 0;"></div> </div> <h2 class="gd-best-phones-heading" style="clear:both;">Best Phones</h2> <div class="oi-bestphones" id="best_widget"></div> <div style="padding-top:10px;"></div> <div id="upcoming_phones_widget_id_new"></div> <div id="rightSticky" style="clear: both; min-height:600px;"> <div id="div-gpt-ad-1384320970624-2" data-exec=0 data-adval=0 data-elementid="7" class="oiad oi-axt"></div> </div> </div> </div> <div class="clear"></div> </div> <div class="giz-overlay"></div> <link rel="stylesheet" href="/common/css/font-awesome.min.css"/> <style>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</style> <style>

#footerMain.stickyfooter {
    position: fixed;
    bottom: 0;
    z-index: 999999999;
    height: 500px;
    background: #fff;
    width: 1280px;
}

	.oi-footer-bottom-ad-btns {
    margin: 0 auto;
    text-align: center;
    position: fixed;
    right: 150px;
    bottom: 100px;
    display: none;
}
.oi-footer-bottom-ad-btns a {
    width: 34px;
    height: 34px;
    border-radius: 50%;
    margin: 0 5px;
    box-shadow: 0 3px 4px #a2a2a2;
    display: block;
    margin-bottom: 5px;
}
		.oi-footer-bottom-icon {background: url(/images/footer-bottom-arrow.svg) no-repeat 0 0;}
		.oi-footer-top-icon {background: url(/images/footer-top-arrow.svg) no-repeat 0 0;}
.oi-footer-close {
    background: url(/images/close-btn.svg) no-repeat center center;
    width: 30px;
    height: 30px;
    display: block;
    margin: 10px 3px 7px 5px;
    position: absolute;
    right: 0px;
    bottom: 494px;
    cursor: pointer;
    z-index: 99999999999;
    display: none;
}

#footerMain.hidestickyfooter {
    position: fixed;
    bottom: 0;
    height: 0;
}
#footerMain{
	  moz-transition: all 0.27s ease-in;
    -o-transition: all 0.27s ease-in;
    -webkit-transition: all 0.27s ease-in;
    transition: all 0.27s ease-in;
}
.oi-footer-comment-icon {
    background: url(/images/cmtnewicon.svg) no-repeat 0 0;
    position: relative;
    z-index: 99999;
}
span.commentsToolTip {
    background: #FF4423;
    font-family: arial;
    color: #fff;
    float: left;
    width: 123px;
    padding: 3px 2px;
    border-radius: 14px;
    font-size: 13px;
    position: absolute;
    right: -300px;
    top: 6px;
    line-height: 16px;
    z-index: 99;
      webkit-transform: translateX(0);
    -moz-transform: translateX(0);
    -ms-transform: translateX(0);
    transform: translateX(0);
    -webkit-transition: all .4s cubic-bezier(.37, .15, .32, .94);
    -moz-transition: all .4s cubic-bezier(.37, .15, .32, .94);
    -ms-transition: all .4s cubic-bezier(.37, .15, .32, .94);
    transition: all .4s cubic-bezier(.37, .15, .32, .94);
    z-index: 99;
}


.displaytooltip {
    
    right: 32px!important;
  
}


span#text_change {
    background: #FF4423;
    border: 1px solid #FF4423;
    border-radius: 15px;
}
#text_change a {
    color: #fff;
}
.comments-icon {
    display: inline-block;
    margin-left: 5px;
    margin-top: 5px;
    background: url(/images/comment-new.svg) no-repeat 0 0;
    width: 16px;
    height: 20px;
    vertical-align: middle;
    margin-right: 8px;
}
span#text_change {
    width: 240px;
    margin-bottom: 10px;
}
#cmscontent-article1 {
    min-width: 300px;

}
.viroolVideo {
    clear: both;
}
footer#footerMain {
    
    width: 1280px;
}

</style> <div class="oi-footer-bottom-ad-btns"> <a href="#vuukle-comments" class="oi-footer-comment-icon"></a> <span class="commentsToolTip">Click to comments</span> <a href="javascript:void(0);" class="oi-footer-top-icon"></a> <a href="javascript:void(0);" class="oi-footer-bottom-icon"></a> </div> <footer> <div id="footerMain" class="io-article-footer"> <span class="oi-footer-close"></span> <div class="clearfix"> <div class="site-logo"> <a href="/" class="oneindia-logo"><img src="/images/logos/gizbot-logo-on1.svg" alt="Gizbot" height="28"/></a> </div> <div class="site-outerblock"> <div class="site-languages"> <div class="footer-heading"><span></span>Gizbot in Other Languages</div> <ul> <li><a href="https://bengali.gizbot.com/" class="lang-bengali" style="line-height: 11px;padding-bottom: 0;">বাংলা <i class="fa fa-angle-right"></i></a></li> <li><a href="https://gujarati.gizbot.com/" class="lang-gujarati" style="line-height: 11px;padding-bottom: 0;">ગુજરાતી <i class="fa fa-angle-right"></i></a></li> <li><a href="https://hindi.gizbot.com/" class="lang-hindi" style="line-height: 11px;padding-bottom: 0;">हिन्दी <i class="fa fa-angle-right"></i></a></li> <li><a href="https://kannada.gizbot.com/" class="lang-kannada" style="line-height: 11px;padding-bottom: 0;">ಕನ್ನಡ <i class="fa fa-angle-right"></i></a></li> <li><a href="https://malayalam.gizbot.com/" class="lang-malayalam" style="font-size:14px;line-height: 11px;padding-bottom: 0;">മലയാളം <i class="fa fa-angle-right"></i></a></li> <li><a href="https://tamil.gizbot.com/" class="lang-tamil" style="font-size:14px;line-height: 11px;padding-bottom: 0;">தமிழ் <i class="fa fa-angle-right"></i></a></li> <li><a href="https://telugu.gizbot.com/" class="lang-telugu" style="font-size:15px;line-height: 11px;padding-bottom: 0;">తెలుగు <i class="fa fa-angle-right"></i></a></li> </ul> </div> <div class="site-links" itemscope itemtype="https://www.schema.org/SiteNavigationElement"> <div class="footer-heading"><span></span>Explore Gizbot</div> <ul> <li><a href="/news/" itemprop="url"><i class="fa fa-angle-right"></i><span itemprop="name">News</span></a></li> <li><a href="/wearable-technology/" itemprop="url"><i class="fa fa-angle-right"></i><span itemprop="name">Gear </span></a></li> <li><a href="/tablet/" itemprop="url"><i class="fa fa-angle-right"></i><span itemprop="name">Tablet </span></a></li> <li><a href="/laptop/" itemprop="url"><i class="fa fa-angle-right"></i><span itemprop="name">Laptop </span></a></li> <li><a href="/mobile/" itemprop="url"><i class="fa fa-angle-right"></i><span itemprop="name">Mobile </span></a></li> <li><a href="/gadgets/" itemprop="url"><i class="fa fa-angle-right"></i><span itemprop="name">Gadgets</span></a></li> <li><a href="/photo-feature/" itemprop="url"><i class="fa fa-angle-right"></i><span itemprop="name">Features</span></a></li> <li><a href="/how-to/" itemprop="url"><i class="fa fa-angle-right"></i><span itemprop="name">How-To</span></a></li> <li><a href="/gadget-finder/" itemprop="url"><i class="fa fa-angle-right"></i><span itemprop="name">Gadget Finder</span></a></li> </ul> </div> <div class="other-child-sites"> <div class="footer-heading"><span></span>Other Greynium Sites</div> <ul> <li><a href="https://www.filmibeat.com/" rel="nofollow" class="filmibeat-logo"><span>Filmibeat</span></a></li> <li><a href="https://www.boldsky.com/" rel="nofollow" class="boldsky-logo"><span>Boldsky</span></a></li> <li><a href="https://coupons.oneindia.com/" class="coupons-logo"><span>Coupons</span></a></li> <li><a href="https://www.drivespark.com/" rel="nofollow" class="drivespark-logo"><span>Drivespark</span></a></li> <li><a href="https://www.goodreturns.in/" rel="nofollow" class="goodreturns-logo"><span>Goodreturns</span></a></li> <li><a href="https://www.nativeplanet.com/" rel="nofollow" class="nativeplanet-logo"><span>Native Planet</span></a></li> <li><a href="https://www.careerindia.com/" rel="nofollow" class="careerindia-logo"><span>Careerindia</span></a></li> <li><a href="https://www.click.in/" rel="nofollow" class="clickin-logo"><span>Clickin</span></a></li> </ul> </div> <div class="other-site-details"> <div class="footer-heading"><span></span>Follow Gizbot</div> <div class="footer-bottom-border"> <div class="footer-social-links"> <a href="https://www.facebook.com/gizbot.com" rel="nofollow" class="fb-icon"><i class="fa fa-facebook"></i></a> <a href="https://twitter.com/gizbot" rel="nofollow" class="tw-icon"><i class="fa fa-twitter"></i></a> <a href="https://www.youtube.com/channel/UChpms81A8ItnbXTHgJzx5pg" rel="nofollow" class="yt-icon"><i class="fa fa-youtube"></i></a> </div> </div> <div class="footer-bottom-border"> <div class="footer-subheading">Daily Updates</div> <form target="_blank" class="nospace" action="https://app5.saymails.com/cgi-bin/useradd.pl" method="post" name="newsletter_subscribeform" id="newsletter"> <div class="newsletter-subscribe-box"> <input type="hidden" name="city" id="newsletter_city"/> <input type="hidden" name="country" id="newsletter_country"/> <input type="hidden" name="dbname1" value="b25laW5kaWE="/> <input type="hidden" name="listname1" value="Z2l6Ym90"/> <input type="hidden" name="action1"> <input type="text" name="email" placeholder="Enter Your Email Address" class="newsletter-textbox" id="email"/> <input type="submit" name="subscribe" value="Sign Up" class="newsletter-submit-btn" onclick="return postformById('useradd',this.form);"/> <div class="clear"></div> </div> </form> </div> </div> <div class="clear"></div> </div> <div class="footer-links"> <a href="/aboutus.html">About Us</a> | <a href="https://www.greynium.com/terms-of-service" rel="nofollow">Terms of Service</a> | <a href="https://www.greynium.com/privacy-policy" rel="nofollow">Privacy Policy</a> | <a href="/rss/">RSS</a> | <a href="/contact.html">Contact Us</a> | <a href="https://www.greynium.com/feedback" rel="nofollow">Feedback</a> | <a href="/sitemap/">Sitemap</a> | <a href="/common/cookies/change-cookie-settings.html" target="_blank" rel="nofollow">Cookie Policy</a> | <a href="https://www.greynium.com/code-of-business-conduct" target="_blank" rel="nofollow">Code of Business Conduct</a> </div> <div class="copyright-text">&copy; <span id="curYear"></span> Greynium Information Technologies Pvt. Ltd. All Rights Reserved.</div> </div> </div> </footer> </div> </div> <div class="lightbox-videos-overlay"></div> <div class="lightbox-popup-videos-wrapper"> <div class="lightbox-popup-videos-close"><a href="javascript:void(0);">Close <i class="fa fa-times"></i></a></div> <div class="lightbox-popup-videos-container-parent"> <div class="lightbox-popup-videos-container"> <div class="lightbox-popup-videos-left"> <div class="lightbox-popup-video" id="lightbox-popup-video"> </div> <div class="lightbox-popup-video-heading"> <span id="lightbox-popup-video-heading"></span> <div class="lightbox-popup-videos-socialinks" id="lightbox-videos-share-links" data-share-url="" data-share-title="" data-share-image=""> <a href="#" class="social-icons facebook light-share-fb"><i class="fa fa-facebook"></i></a> <a href="#" class="social-icons twitter light-share-twitter"><i class="fa fa-twitter"></i></a> </div> </div> </div> <div class="lightbox-popup-videos-right"> <div class="lightbox-popup-ad" id="lightbox-popup-ad"></div> </div> <div class="lightbox-popup-clear"></div> </div> </div> <div class="lightbox-popup-morevideos" id="lightbox-popup-morevideos"> <ul class="oneindia-fl-videos"></ul> <ul class="filmibeat-fl-videos"></ul> <ul class="boldsky-fl-videos"></ul> <ul class="gizbot-fl-videos"></ul> </div> </div> <script type="text/javascript" data-pagespeed-no-defer>pagespeed.lazyLoadImages.overrideAttributeFunctions();</script><script src="https://apis.google.com/js/platform.js"></script> <style type="text/css">
#notify-subscribe {
    font-weight: bold;
    color: #0066cc;
    text-decoration: underline;
    cursor: pointer;
}
</style> <link type="text/css" rel="stylesheet" href="/common/min/?b=common/adaptive/css&f=desktop-notification.css&v=10"/> <div class="notf-overlay"></div> <div class="instant-updates-bottom" id="oiNotification"> <div class="instant-updates-mid"> <div class="instant-updates-left" id="enable-btn"> <div class="instant-updates-content"> <div class="instant-updates-bellicon"> <i class="updates-bellicon"></i> </div> <span>Get Instant News Updates</span> </div> <div class="instant-updates-arrow">Enable</div> </div> <span class="instant-updates-close">x</span> </div> </div> <div class="article-overlay"></div> <div class="notification-settings-popup"> <a href="javascript:void(0);" class="notification-settings notfset"><i class="fa fa-arrow-left"></i> Notification Settings</a> <a href="javascript:void(0);" class="article-popup-close">X</a> <div class="notification-overflow"> <div class="notification-settings-content"> <div class="notification-settings-heading">Time Settings</div> <div class="notification-settings-details clearfix"> <ul> <li><div class="compare-radio"> <label> <div class="squaredradio"> <input class="filter_by" name="block-radio" value="0" type="radio" checked="checked"> <i for="squaredradio"></i> </div> <span class="name">Don't Block</span> </label> </div> </li> <li><div class="compare-radio"> <label> <div class="squaredradio"> <input class="filter_by" name="block-radio" value="8" type="radio"> <i for="squaredradio"></i> </div> <span class="name">Block for 8 hours</span> </label> </div> </li> <li><div class="compare-radio"> <label> <div class="squaredradio"> <input class="filter_by" name="block-radio" value="12" type="radio"> <i for="squaredradio"></i> </div> <span class="name">Block for 12 hours</span> </label> </div> </li> <li><div class="compare-radio"> <label> <div class="squaredradio"> <input class="filter_by" name="block-radio" value="24" type="radio"> <i for="squaredradio"></i> </div> <span class="name">Block for 24 hours</span> </label> </div> </li> <li><div class="compare-radio"> <label> <div class="squaredradio"> <input class="filter_by" name="block-radio" value="1" type="radio"> <i for="squaredradio"></i> </div> <div class="name">
Dont send alerts during
<select class="alerts-time-selbox" id="block-from" name="" disabled="disabled"> <option value="1">1 am</option> <option value="2">2 am</option> <option value="3">3 am</option> <option value="4">4 am</option> <option value="5">5 am</option> <option value="6">6 am</option> <option value="7">7 am</option> <option value="8">8 am</option> <option value="9">9 am</option> <option value="10">10 am</option> <option value="11">11 am</option> <option value="12">12 pm</option> <option value="13">1 pm</option> <option value="14">2 pm</option> <option value="15">3 pm</option> <option value="16">4 pm</option> <option value="17">5 pm</option> <option value="18">6 pm</option> <option value="19">7 pm</option> <option value="20">8 pm</option> <option value="21">9 pm</option> <option value="22">10 pm</option> <option value="23">11 pm</option> <option value="24">12 am</option> </select>
to
<select class="alerts-time-selbox" id="block-to" name="" disabled="disabled"> <option value="1">1 am</option> <option value="2">2 am</option> <option value="3">3 am</option> <option value="4">4 am</option> <option value="5">5 am</option> <option value="6">6 am</option> <option value="7">7 am</option> <option value="8">8 am</option> <option value="9">9 am</option> <option value="10">10 am</option> <option value="11">11 am</option> <option value="12">12 pm</option> <option value="13">1 pm</option> <option value="14">2 pm</option> <option value="15">3 pm</option> <option value="16">4 pm</option> <option value="17">5 pm</option> <option value="18">6 pm</option> <option value="19">7 pm</option> <option value="20">8 pm</option> <option value="21">9 pm</option> <option value="22">10 pm</option> <option value="23">11 pm</option> <option value="24">12 am</option> </select> </div> </label> </div> </li> <li><div class="compare-radio"> <label> <div class="squaredradio"> <input class="filter_by" name="block-radio" value="9999" type="radio"> <i for="squaredradio"></i> </div> <span class="name">Switch Off</span> </label> </div> </li> </ul> </div> <span id="error_msg"></span> </div> <div class="notification-settings-bottomcontent"> <div class="notification-settings-clear"> <div class="notification-settings-heading" id="clear-inbox" style="display: none;">Clear My <a href="javascript:void(0);">notification inbox</a></div> </div> </div> <div class="notification-settings-btn">
Done
</div> </div> </div> <div class="notification-settings-clearbox"> <a href="javascript:void(0);" class="notification-settings clearnotf"><i class="fa fa-arrow-left"></i> Clear Notification</a> <a href="javascript:void(0);" class="article-popup-close">X</a> <div class="notification-overflow-clearbox"> <div class="notification-settings-heading">Do you want to clear all the notifications from your inbox?</div> </div> <div class="notification-settings-btn"> <a href="javascript:void(0);" class="yes">Yes</a> <a href="javascript:void(0);" class="no">No</a> </div> </div> <div class="article-slider-wrapper"> <a href="javascript:void(0);" class="article-popup-settings">Settings</a> <a href="javascript:void(0);" class="article-popup-close">X</a> <div class="article-slider"> <ul id="notification-content"> </ul> </div> <div class="article-slider-container" style="display: none;"> <div class="no-notification-wrapper"> <div class="no-notif-content"> <span>0</span> </div> <div class="no-notif-text">No New Notifications</div> </div> </div> </div> </div> </div> <div id="bottom_content"></div> <script type="text/javascript">function getUserCookie(c_name){var c_value=document.cookie;var c_start=c_value.indexOf(" "+c_name+"=");if(c_start==-1){c_start=c_value.indexOf(c_name+"=");}if(c_start==-1){c_value=null;}else{c_start=c_value.indexOf("=",c_start)+1;var c_end=c_value.indexOf(";",c_start);if(c_end==-1){c_end=c_value.length;}c_value=unescape(c_value.substring(c_start,c_end));}return c_value;}var d=new Date();var n=d.getMilliseconds();var urlburst='v='+n;if(window.location.search==='?staging'){var conFile='/common/oijs/oiframework-desk-app-stag.js?'+urlburst;}else{var conFile='/common/build/js/oiframework-desk-app.min.js?v=2.8.85';}['/common/app/lib/require-latest.js',conFile].forEach(function(src){var script=document.createElement('script');script.src=src;script.async=false;document.head.appendChild(script);});</script> <noscript> <img src="https://b.scorecardresearch.com/p?c1=2&c2=7732551&cv=2.0&cj=1"/> </noscript> <noscript> <div style="display: none;"> <img src="//pixel.quantserve.com/pixel/p-yjta2aSVPaHEL.gif" height="1" width="1" alt="Quantcast"/> </div> </noscript> <div data-id="3" data-step="1" class="oneindia_widget_container" id="oneindia_widget_container_1328"></div> <script type="text/javascript">if(document.getElementById("containerMain")&&document.getElementById("containerMain").hasAttribute("data-page_type")){var pageType=document.getElementById("containerMain").getAttribute("data-page_type");if(pageType=='article'){if(icrflagad&&jioAdsenabled){var jio_slots_config=[{"name":"oi-hi-web-728x90","zone_key":"5oi861bw","zone_id":18151,"uid":"oideskhi1","loadflag":1},{"name":"oi-hi-web-160x600","zone_key":"e5jw48xa","zone_id":18154,"uid":"oideskhi2","loadflag":1},{"name":"oi-hi-web-300x250","zone_key":"tckhlyx1","zone_id":18184,"uid":"oideskhi3","loadflag":1},{"name":"oi-hi-web-inarticle-300x250-5","zone_key":"oj6u5n18","zone_id":18169,"uid":"oideskhi8","loadflag":1}];var jio_inarticle_slots_config=[{"name":"oi-hi-web-inarticle-300x250-1","zone_key":"lfks6mav","zone_id":18157,"uid":"oideskhi4","loadflag":1},{"name":"oi-hi-web-inarticle-300x250-2","zone_key":"w7bh6mx9","zone_id":18187,"uid":"oideskhi5","loadflag":1},{"name":"oi-hi-web-inarticle-300x250-3","zone_key":"pt0k7mhr","zone_id":18163,"uid":"oideskhi6","loadflag":1},{"name":"oi-hi-web-inarticle-300x250-4","zone_key":"qpjltvc5","zone_id":18166,"uid":"oideskhi7","loadflag":1}];var jio_source='gizbot'
if(document.querySelector('.cmscontent-top')){var adelem=document.querySelector('.cmscontent-top');var loadstatus=jio_slots_config[0]['loadflag'];if(loadstatus){adelem.innerHTML='';var jioDiv=document.createElement('ins');jioDiv.id=jio_slots_config[0]['uid'];jioDiv.setAttribute('data-adspot-key',jio_slots_config[0]['zone_key']);jioDiv.setAttribute('data-source',jio_source);jioDiv.setAttribute('data-refresh-rate',30);adelem.appendChild(jioDiv);}}if(document.querySelector('.cmscontent-left-article')){var adelem=document.querySelector('.cmscontent-left-article');var loadstatus=jio_slots_config[1]['loadflag'];if(loadstatus){adelem.innerHTML='';var jioDiv=document.createElement('ins');jioDiv.id=jio_slots_config[1]['uid'];jioDiv.setAttribute('data-adspot-key',jio_slots_config[1]['zone_key']);jioDiv.setAttribute('data-source',jio_source);jioDiv.setAttribute('data-refresh-rate',30);adelem.appendChild(jioDiv);}}if(document.querySelector('.cmscontent-right1')){var adelem=document.querySelector('.cmscontent-right1');var loadstatus=jio_slots_config[2]['loadflag'];if(loadstatus){adelem.innerHTML='';var jioDiv=document.createElement('ins');jioDiv.id=jio_slots_config[2]['uid'];jioDiv.setAttribute('data-adspot-key',jio_slots_config[2]['zone_key']);jioDiv.setAttribute('data-source',jio_source);jioDiv.setAttribute('data-refresh-rate',30);adelem.appendChild(jioDiv);}}if(document.querySelector('.cmscontent-right2')){var adelem=document.querySelector('.cmscontent-right2');var loadstatus=jio_slots_config[3]['loadflag'];if(loadstatus){adelem.innerHTML='';var jioDiv=document.createElement('ins');jioDiv.id=jio_slots_config[3]['uid'];jioDiv.setAttribute('data-adspot-key',jio_slots_config[3]['zone_key']);jioDiv.setAttribute('data-source',jio_source);jioDiv.setAttribute('data-refresh-rate',30);adelem.appendChild(jioDiv);}}if(document.querySelector('.refreshInarticleAd')){var adelem=document.querySelectorAll('.refreshInarticleAd');var adelemlen=adelem.length;if(adelemlen>0){for(g=0;g<adelemlen;g++){if(jio_inarticle_slots_config[g]){var loadstatus=jio_inarticle_slots_config[g]['loadflag'];if(loadstatus){adelem[g].innerHTML='';var jioDiv=document.createElement('ins');jioDiv.id=jio_inarticle_slots_config[g]['uid'];jioDiv.setAttribute('data-adspot-key',jio_inarticle_slots_config[g]['zone_key']);jioDiv.setAttribute('data-source',jio_source);jioDiv.setAttribute('data-refresh-rate',30);adelem[g].appendChild(jioDiv);}}}}}window.addEventListener('DOMContentLoaded',function(){JioAds.setConfiguration({logLevel:1});});}}}if(window.location.search.indexOf('ua=1')>-1){var newua=navigator.userAgent;document.querySelector('.heading').innerHTML=newua;}var taboolaPageType='category';if(document.getElementById("containerMain")&&document.getElementById("containerMain").hasAttribute("data-page_type")){taboolaPageType=document.getElementById("containerMain").getAttribute("data-page_type");}function taboola_main(){window._taboola=window._taboola||[];if(taboolaPageType==='homepage'){_taboola.push({homepage:'auto'});}else if(taboolaPageType==='article'){_taboola.push({article:'auto'});}else{_taboola.push({category:'auto'});}!function(e,f,u,i){if(!document.getElementById(i)){e.async=1;e.src=u;e.id=i;f.parentNode.insertBefore(e,f);}}(document.createElement('script'),document.getElementsByTagName('script')[0],'//cdn.taboola.com/libtrc/oneindiadigital-gizbotenglish/loader.js','tb_loader_script');if(window.performance&&typeof window.performance.mark=='function'){window.performance.mark('tbl_ic');}}taboola_main();</script> <script>function getTaboolaWidget(mode,container,placement,target_type){window._taboola=window._taboola||[];_taboola.push({mode:mode,container:container,placement:placement,category:'english',target_type:target_type});}if(document.getElementById("taboola-below-article-thumbnails")){var mode='thumbs-feed-01-a';var container='taboola-below-article-thumbnails';var placement='Below Article Thumbnails';var target_type='mix';getTaboolaWidget(mode,container,placement,target_type);}if(document.getElementById("taboola-mid-article-thumbnails")){var mode='thumbnails-a-mid';var container='taboola-mid-article-thumbnails';var placement='Mid Article Thumbnails';var target_type='mix';getTaboolaWidget(mode,container,placement,target_type);}if(document.getElementById("taboola-right-rail-thumbnails")){var mode='thumbnails-rr';var container='taboola-right-rail-thumbnails';var placement='Right Rail Thumbnails';var target_type='mix';getTaboolaWidget(mode,container,placement,target_type);}if(document.getElementById("taboola-below-category-thumbnails")){var mode='thumbnails-a-section';var container='taboola-below-category-thumbnails';var placement='Below Category Thumbnails';var target_type='mix';getTaboolaWidget(mode,container,placement,target_type);}if(document.getElementById("taboola-below-homepage-thumbnails")){var mode='thumbnails-a-hp';var container='taboola-below-homepage-thumbnails';var placement='Below Homepage Thumbnails';var target_type='mix';getTaboolaWidget(mode,container,placement,target_type);}if(document.getElementById("taboola-mid-home-stream-1")){var mode='thumbs-feed-01-stream';var container='taboola-mid-home-stream-1';var placement='Mid Home Stream 1';var target_type='mix';getTaboolaWidget(mode,container,placement,target_type);}if(document.getElementById("taboola-mid-home-stream-2")){var mode='thumbs-feed-01-stream';var container='taboola-mid-home-stream-2';var placement='Mid Home Stream 2';var target_type='mix';getTaboolaWidget(mode,container,placement,target_type);}if(document.getElementById("taboola-mid-category-thumbnails")){var mode='thumbnails-a-mid';var container='taboola-mid-category-thumbnails';var placement='Mid Category Thumbnails';var target_type='mix';getTaboolaWidget(mode,container,placement,target_type);}if(document.getElementById("taboola-below-home-thumbnails")){var mode='alternating-thumbnails-a';var container='taboola-below-home-thumbnails';var placement='Below Home Thumbnails';var target_type='mix';getTaboolaWidget(mode,container,placement,target_type);}window._taboola=window._taboola||[];_taboola.push({flush:true});</script> <script>if(no_ad_flag==true){if(document.querySelector('.cms-videos-wrapper')){document.querySelector('.cms-videos-wrapper').style.display='none';}if(document.querySelector('.assigned_video_heading')){document.querySelector('.assigned_video_heading').style.display='none';}if(document.querySelector('.youtube_embed_video_list')){document.querySelectorAll('.youtube_embed_video_list').forEach(e=>e.remove());}if(document.querySelector('.gallery-embed-heading')){document.querySelectorAll('.gallery-embed-heading').forEach(e=>e.remove());}if(document.querySelector('.header-ads')){}if(document.querySelector('.cmscontent-right1')){}if(document.querySelector('.cmscontent-left-article')){}}</script> <script>if(window.location.search.indexOf('oirev_analyse')>-1){var today=new Date();var y=today.getFullYear();var m=today.getMonth()+1;var d=today.getDate();var hr=today.getHours();var min=today.getMinutes();var urlBurstParam1=y+''+m+''+d+''+hr+''+min;var tag1=document.createElement('script');tag1.src='https://rss.oneindia.com/common/oi-debug.js?v='+urlBurstParam1;tag1.async=true;tag1.id='oiscripts1';var firstScriptTag1=document.getElementsByTagName('script')[0];firstScriptTag1.parentNode.insertBefore(tag1,firstScriptTag1);}</script> <script>var ga_ad_block="Adblock";var hostname=window.location.hostname;var oiab_done=false;function loadScript(path,callback){var scr=document.createElement('script');scr.onerror=handleError;scr.async=true;scr.src=path;document.body.appendChild(scr);function handleError(){console.log('handleError');if(!oiab_done){oiab_done=true;loadwhenAB();}}}loadScript("https://"+hostname+"/common/js/ads.js");function loadwhenAB(){console.log('inside AB function');if(document.getElementById('zQyHLKpYGvgh')){console.log('Without Ad Blocker');}else{ga('gizboten.set','dimension6',ga_ad_block);(function(){var today=new Date();var urlBurstParam=today.getHours();var commontag=document.createElement('script');commontag.src='https://rss.oneindia.com/common/oi-inhouse-scripts.js?lang=en&domain='+hostname;commontag.async=true;commontag.id='oiinhousescripts';var firstcommonScriptTag=document.getElementsByTagName('script')[0];firstcommonScriptTag.parentNode.insertBefore(commontag,firstcommonScriptTag);}());}}</script> <script type="text/javascript">(function(){var hidden="hidden";if(hidden in document)document.addEventListener("visibilitychange",onchange);else if((hidden="mozHidden")in document)document.addEventListener("mozvisibilitychange",onchange);else if((hidden="webkitHidden")in document)document.addEventListener("webkitvisibilitychange",onchange);else if((hidden="msHidden")in document)document.addEventListener("msvisibilitychange",onchange);else if("onfocusin"in document)document.onfocusin=document.onfocusout=onchange;else
window.onpageshow=window.onpagehide=window.onfocus=window.onblur=onchange;function onchange(evt){var v="visible",h="hidden",evtMap={focus:v,focusin:v,pageshow:v,blur:h,focusout:h,pagehide:h};evt=evt||window.event;if(evt.type in evtMap)document.body.className=evtMap[evt.type];else
document.body.className=this[hidden]?"hidden":"visible";}if(document[hidden]!==undefined)onchange({type:document[hidden]?"blur":"focus"});})();</script> <script>function setUserCookie(name,value,expires,path,domain,secure){var chkcookiepolicy=getUserCookie('cookiePolicy');console.log(chkcookiepolicy);if(chkcookiepolicy!=0){var today=new Date();today.setTime(today.getTime());if(expires){expires=expires*1000*60*60;}var expires_date=new Date(today.getTime()+(expires));document.cookie=name+'='+escape(value)+((expires)?';expires='+expires_date.toGMTString():'')+((path)?';path='+path:'')+((domain)?';domain='+domain:'')+((secure)?';secure':'');}}function deleteUserCookie(name,path,domain){if(getUserCookie(name))document.cookie=name+'='+((path)?';path='+path:'')+((domain)?';domain='+domain:'')+';expires=Thu, 01-Jan-1970 00:00:01 GMT';}function checkUserCookie(cookie_name){var location_details=getUserCookie(cookie_name);if(location_details==null||location_details==""){return false;}else if(location_details!=""){return true;}}function getUserCookie(c_name){var c_value=document.cookie;var c_start=c_value.indexOf(" "+c_name+"=");if(c_start==-1){c_start=c_value.indexOf(c_name+"=");}if(c_start==-1){c_value=null;}else{c_start=c_value.indexOf("=",c_start)+1;var c_end=c_value.indexOf(";",c_start);if(c_end==-1){c_end=c_value.length;}c_value=unescape(c_value.substring(c_start,c_end));}return c_value;}</script> <div class="non-friendly-scatter"> <div id="z69e7a65d-c808-4acc-a72c-6433b6856ba9" style='display:none'></div> </div> <style>
	.amazon-ad-link {
    background: #e2f5d2 none repeat scroll 0 0;
    border-radius: 3px;
    color: #000;
    font-weight: bold;
    padding: 2px 5px;
    text-decoration: none;
}
.amazon-ad-link:hover {
    background: #629c49;
    color: #fff;
    text-decoration: none;
}
</style> <script>function SetYear(){console.log("year");var thisDate=new Date();var thisYear=thisDate.getFullYear();document.getElementById('curYear').innerHTML=thisYear;}try{if(document.getElementById('curYear')){SetYear();}}catch(err){console.log("curYear Block : "+err);}</script> <noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=422563459298864&ev=PageView&noscript=1" alt="facebookview"/></noscript> <script type="text/javascript">function getBrowserName(){var name="";if((/(chrome\/)(\d+\.\d+)/i.test(navigator.userAgent)&&navigator.userAgent.search("UCBrowser")<0)&&(/(chrome\/)(\d+\.\d+)/i.test(navigator.userAgent)&&navigator.userAgent.search("Edge")<0)&&(/(chrome\/)(\d+\.\d+)/i.test(navigator.userAgent)&&navigator.userAgent.search("UBrowser")<0)){name="Chrome";}else if(navigator.userAgent.indexOf("MSIE")!=-1){name="MSIE";}else if(navigator.userAgent.indexOf("Firefox")!=-1){name="Firefox";}else if(navigator.userAgent.indexOf("Opera")!=-1){name="Opera";}else if(navigator.userAgent.indexOf("Safari")!=-1){name="Safari";}return name;}function trackEventsforExtension(){ga('gizboten.send','event','cms-plugins','extn-addon',label);}var browserCheck=getBrowserName();console.log(browserCheck+"browser");var label;if(browserCheck==='Chrome'){if(document.querySelector(".browser_extension")){var current_link='https://chrome.google.com/webstore/detail/gizbot/eepjeonpojdmeipdhjiochmpgbnjaaae?hl=en';document.querySelector(".browser_extension").setAttribute('href',current_link);label='chrome';}if(document.querySelector(".extensionElem")){document.querySelector(".extensionElem").style.display='block';}}else if(browserCheck==='Firefox'){if(document.querySelector(".browser_extension")){var current_link='https://addons.mozilla.org/en-GB/firefox/addon/oneindia-news/';document.querySelector(".browser_extension").setAttribute('href',current_link);label='firefox';}if(document.querySelector(".extensionElem")){document.querySelector(".extensionElem").style.display='block';}}if(document.querySelector(".browser_extension")){var clickObj=document.querySelector(".browser_extension");clickObj.onclick=trackEventsforExtension;}</script> <iframe id="multisync-iframe" height="0" width="0" marginwidth="0" marginheight="0" scrolling="no" frameborder="0" src="https://secure-assets.rubiconproject.com/utils/xapi/multi-sync.html?p=dfp&endpoint=apac" style="border: 0px; display: none;"></iframe> <script>if(document.getElementById("right-native-ad")){var slotpos='rightInclude';var tcode='RB';}else if(document.getElementById("oiNativePromo1")){var slotpos='homeInclude';var tcode='HP';}else{var slotpos='indexInclude';var tcode='IP';}(function(){var host='GZEN';var lang='en';var randomh=Math.random();var curl=window.location.href;var e=document.getElementsByTagName("script")[0];var d=document.createElement("script");d.src="https://rss.oneindia.com/cms/render-native-ad.js?slotpos="+slotpos+"&trackcode="+tcode;d.type="text/javascript";d.async=true;d.id="nativeadjs";e.parentNode.insertBefore(d,e);})();</script> <script>function createCookie(name,value,days){if(days){var date=new Date();date.setTime(date.getTime()+(days*24*60*60*1000));var expires="; expires="+date.toGMTString();}else var expires="";document.cookie=name+"="+value+expires+"; path=/";}function eraseCookie(name){createCookie(name,"",-1);}function removeCookies(){var cookies=document.cookie.split(";");for(var i=0;i<cookies.length;i++){eraseCookie(cookies[i].split("=")[0]);}}var chkcookiepolicy=getUserCookie('cookiePolicy');console.log(chkcookiepolicy+" : Country Found");if(typeof(chkcookiepolicy)=="undefined"||chkcookiepolicy==null){setUserCookie('cookiePolicy',1,'','/','','');}</script> <script type="text/javascript" data-pagespeed-no-defer>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</script> <script>if(document.getElementById("adg_related_right")){document.getElementById("adg_related_right").innerHTML='<li class="clearfix"><div class="adg_native_home" data-templateId_slotId="1333_0" data-nanoNativeFlag="1" style="display:none;"><a href="#" class="nano_promo_right_a"><img src="#" class="nano_promo_right_img"></a></div></li>';}</script> <script>function removeElement(id){var elem=document.getElementById(id);elem.parentNode.removeChild(elem);}if(document.getElementById("containerMain")){var pageType=document.getElementById("containerMain").getAttribute("data-page_type");if(pageType=='homepage'){var duplicateIds=['div-gpt-ad-1384320856135-2'];}else if(pageType=='article'){var duplicateIds=['div-gpt-ad-1384320856135-5'];}else{var duplicateIds=['div-gpt-ad-1384320856135-5'];}for(i=0;i<duplicateIds.length;i++){var remId=duplicateIds[i];removeElement(remId);}}</script> <script type="text/javascript">var adElem=[];var adObj={};googletag.cmd.push(function(){googletag.pubads().addEventListener('slotRenderEnded',function(event){var slotId=event.slot.getSlotElementId();var slotName=event.slot.getAdUnitPath();adObj[slotName]=slotId;});adElem.push(adObj);});console.log("DFP AD units: ");console.log(adElem);</script> <style type="text/css">
#oiBottomAd1 {
    position: fixed;
    bottom: 10px;
    z-index: 10000000;
    width: 300px;
    height: 250px;
    margin: 0 auto;
    display: none;
  }
.close-ad {position: absolute;right: -10px;top: -20px;width: 20px;height: 20px;background: #000 ;z-index: 10000000;cursor: pointer;color: #fff;font-size: 14px;font-weight: bold;text-align: center;border-radius: 50%;font-family: Arial;line-height: 20px;display: none;}
</style> <div id="oiBottomAd1"> <span class="close-ad" onclick="hideAD1()">X</span> <div id='div-gpt-ad-1577952174933-0' style='width: 300px; height: 250px;'></div> </div> <script>function hideAD1(){document.getElementById("oiBottomAd1").style.display='none';}</script> <div id="gotoTop" style="display: none;"><i class="fa fa-angle-up"></i></div> <style type="text/css">
  #gotoTop {
    background-color: #908a8b;
    border-radius: 2px;
    bottom: 10px;
    color: #fff;
    cursor: pointer;
    display: none;
    font-size: 20px;
    height: 40px;
    left: auto;
    line-height: 36px;
    position: fixed;
    right: 360px;
    text-align: center;
    top: auto;
    width: 40px;
    z-index: 10009;
}
</style> <script type="text/javascript">var origurl=window.location.href;var ga_limit=10;var ga_count=0;if(document.getElementsByClassName("highlights_back")){function googleAnalyticsCommonBottom(){var main_url=document.location.href;;var pattern='https://'+window.location.hostname;var url=main_url.replace(pattern,"");var title=document.title;ga("gizboten.send",{hitType:"pageview",page:url,location:main_url});ga("rosgizbot.send",{hitType:"pageview",page:url,location:main_url});url=document.location.href;var jcode='var _comscore = _comscore || []; var comscoreParams = { c1: "2", c2: "7732551", c3: "", c4: "'+url+'", c5: "", c6: "", c15: "" }; _comscore.push(comscoreParams); var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true; s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js"; el.parentNode.insertBefore(s, el);';setTimeout(jcode,500);}function goToTopFunction(){document.querySelector('#oi-post-highlight-block').scrollIntoView({behavior:'smooth',block:'center'});window.history.pushState({},"",origurl);if(document.getElementById('gotoTop')){document.getElementById('gotoTop').style.display='none';}}function showBackLink(hrefAttr){if(document.getElementById('gotoTop')){document.getElementById('gotoTop').style.display='block';window.history.pushState({},"",hrefAttr);if(ga_count<ga_limit){ga_count++;googleAnalyticsCommonBottom();}document.getElementById("gotoTop").onclick=function(){goToTopFunction()};}}var highlightclassname=document.getElementsByClassName("highlights_back");var myClickAnchorFunction=function(e){var hrefAttr=this.getAttribute("href");showBackLink(hrefAttr);};for(var i=0;i<highlightclassname.length;i++){highlightclassname[i].addEventListener('click',myClickAnchorFunction,false);}}</script> <script type="text/javascript">var breakInt;var chkadcookie=getUserCookie('ad_display_status');var sub_id=localStorage.getItem("gzenglish_subscription_id");if(chkadcookie==null||chkadcookie==undefined||chkadcookie==''){chkadcookie='';}var chkadcookiemor=localStorage.getItem('ad_display_status_mor');if(chkadcookiemor==null||chkadcookiemor==undefined||chkadcookiemor==''){chkadcookiemor='';}var chkadcookieeve=localStorage.getItem('ad_display_status_eve');if(chkadcookieeve==null||chkadcookieeve==undefined||chkadcookieeve==''){chkadcookieeve='';}var camp_id=localStorage.getItem("ad_campiagn");if(camp_id==null||camp_id==undefined||camp_id==''){camp_id='';}var displayFlag=0;var dynamicNotification={createAdCookie:function(name,value,days){if(days){var date=new Date();date.setTime(date.getTime()+(days*24*60*60*1000));var expires="; expires="+date.toGMTString();}else var expires="";document.cookie=name+"="+value+expires+"; path=/";},displayNotification:function(body,notificationImage,icon,title,link,duration,slotFlg,currentDay,adCamp){link=link||0;duration=duration||3000;icon=icon+'?url='+link;var options={type:"image",body:body,icon:icon,image:notificationImage,requireInteraction:true}
navigator.serviceWorker.ready.then(function(registration){registration.showNotification(title,options);if(slotFlg==0){localStorage.setItem('ad_display_status_mor',currentDay);}else{localStorage.setItem('ad_display_status_eve',currentDay);}localStorage.setItem('ad_campiagn',adCamp);});},displayTime:function(){var displayHourMor=[8,13];var displayHourEve=[15,23];var theDate=new Date();var currentDay=Math.abs(theDate.getDate());var currentHour=Math.abs(theDate.getHours());if((currentHour>=displayHourEve[0]&&currentHour<=displayHourEve[1])&&(chkadcookieeve==''||chkadcookieeve!=currentDay)){clearInterval(breakInt);dynamicNotification.checkStatus(1,currentDay);}},trackImpression:function(impUrl){fetch(impUrl,{method:"post"}).catch(function(err){console.error('Inside Imp error:',err);});},fetchDynamicAd:function(sub_id,slotFlg,currentDay){var no_ads=1;var device_type=1;fetch("/scripts/cms/controller.php?module=subscription&type=getBiddingAd&last_sub_id="+sub_id+"&device_type="+device_type+"&noAds="+no_ads+"&campid="+camp_id,{method:"post"}).then(function(e){e.text().then(function(data){adgebraResponse=data;if(adgebraResponse!=''&&adgebraResponse!=undefined){var adgRes=JSON.parse(adgebraResponse);if(adgRes[0]!=''&&adgRes[0]!=undefined&&adgRes[0]!=null){if(adgRes[0]['ad_provider']==='Veve'){var adgUrl=adgRes[0]['trackerUrl'];var impUrl=adgRes[0]['notificationImp'];var adgTitle=adgRes[0]['notificationTitle'];var adgMsg=adgRes[0]['notificationMessage'];dynamicNotification.trackImpression(impUrl);}else{var adgUrl=decodeURIComponent(adgRes[0]['trackerUrl']).replace(/\+/g,' ');var adgTitle=decodeURIComponent(adgRes[0]['notificationTitle']).replace(/\+/g,' ');var adgMsg=decodeURIComponent(adgRes[0]['notificationMessage']).replace(/\+/g,' ');}var adgImg=adgRes[0]['notificationImage'];var adgIcon=adgRes[0]['icon'];var adCamp=adgRes[0]['campId'];dynamicNotification.displayNotification(adgMsg,adgImg,adgIcon,adgTitle,adgUrl,3000,slotFlg,currentDay,adCamp);}}});})["catch"](function(e){console.log("Fetch Error :-S",e)});},checkStatus:function(slotFlg,currentDay){if(sub_id!=""&&sub_id!=undefined&&sub_id!=null){dynamicNotification.fetchDynamicAd(sub_id,slotFlg,currentDay);}},init:function(){if("Notification"in window){var permission=Notification.permission;var userStatus=navigator.onLine;console.log(permission+" User is :"+userStatus);if(permission==="denied"){return;}else if(permission==="granted"&&userStatus){breakInt=setInterval("dynamicNotification.displayTime()",10000);}}}};var qparam=window.location.search;dynamicNotification.init();</script> <script type="text/javascript" data-pagespeed-no-defer>var qParam=document.referrer;var currentHost=document.location.hostname;if(qParam!=''&&qParam.indexOf(currentHost)==-1){(function(window,location){var referrer=document.referrer;if(typeof history!='undefined'&&referrer&&history.length>1){var stateObj={};var goToHomeURL=location.origin+'?utm_medium=Desktop&utm_source=GZ-EN&utm_campaign=Back-Home';history.pushState(stateObj,document.title,location.href);window.addEventListener("popstate",function(){var referrer=document.referrer?document.referrer:'Blank';location.replace(goToHomeURL);},false);}}(window,location));}</script> <script>if(no_ad_flag==true){if(document.getElementById('cmscontent-right1')){}if(document.getElementById('cmscontent-article1')){}if(document.getElementById('cmscontent-article2')){}var elem=document.querySelectorAll('.refreshInarticleAd'),i=0,l=elem.length;for(i;i<l;i++){}}</script> <script>var desipearljsflag=0;function loadDesipearlNano(){var dpaFtSc=document.createElement("script");dpaFtSc.id="dpa_pixel_footer_script";document.head.appendChild(dpaFtSc);dpaFtSc.async=true;dpaFtSc.src="https://www.desipearl.com/advertiser/dpas/dpas.js";}window.addEventListener('scroll',function(){if(desipearljsflag==0){desipearljsflag=1;if(document.getElementById("desipnw")){loadDesipearlNano();}}});</script> <script>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</script> <style>
    #btmFlip{
        display: none!important;
    }
    #coronaflip{
        display: none!important;
    }
    #coflip{
        display: none!important;
    }
.oi-article-lt {
    margin-bottom: 7px!important;
}
#div-gpt-ad-1653012388909-0 iframe{
    width:180px;
    height:180px;
}
</style> <script>var domainArrCamp=['filmibeat','drivespark','goodreturns','oneindia','boldsky','mykhel','careerindia','nativeplanet','gizbot'];if(utmParamVal!=''&&utmParamVal.includes('utm_medium=camp123')||utmParamVal.includes('utm_medium=prodigital_1')||utmParamVal.includes('utm_medium=apex')||utmParamVal.includes('utm_medium=va')||utmParamVal.includes('utm_medium=proformics')||utmParamVal.includes('utm_medium=ZMed')||utmParamVal.includes('utm_medium=vmedia')){if(/Mobi|Android/i.test(navigator.userAgent)){if(domainArrCamp.indexOf(domainmiddle)>'-1'){no_ad_flag=false;}}}</script> <script>var oicontent_oneliner={scriptUrl:'https://content.oneindia.com/www/delivery/asyncjs.php',reviveId:'9de4f035bc8106094a8824fc0cfb6de3',generateInhouseScriptMobi:function(){var backupInhouse=document.createElement("script");backupInhouse.async=true;backupInhouse.type="text/javascript";backupInhouse.src=oicontent_oneliner.scriptUrl;var s=document.getElementsByTagName("script")[0];s.parentNode.insertBefore(backupInhouse,s);},removeJSMobi:function(filename){var tags=document.getElementsByTagName('script');for(var i=tags.length;i>=0;i--){if(tags[i]&&tags[i].getAttribute('src')!=null&&tags[i].getAttribute('src').indexOf(filename)!=-1)tags[i].parentNode.removeChild(tags[i]);}},createInhouseCampaignOneliner:function(zoneId,elemId){var ins_elem=document.createElement("ins");ins_elem.setAttribute("data-revive-target","_blank");ins_elem.setAttribute("data-revive-zoneid",zoneId);ins_elem.setAttribute("data-revive-id",oicontent_oneliner.reviveId);var refnode=document.getElementById(elemId);document.getElementById(elemId).innerHTML='';document.getElementById(elemId).style.display='block';document.getElementById(elemId).appendChild(ins_elem);oicontent_oneliner.removeJSMobi(oicontent_oneliner.scriptUrl);oicontent_oneliner.generateInhouseScriptMobi();}};if(document.getElementById('oneliner-promo')){var scrollExecuteOneliner=0;window.addEventListener("scroll",function(){if(scrollExecuteOneliner==0){scrollExecuteOneliner=1;oicontent_oneliner.createInhouseCampaignOneliner(177,'oneliner-promo');}},false);}</script> <script type="text/javascript" data-pagespeed-no-defer>
 if(window.location.search.indexOf('fid=1')>-1){
	console.log("FID starts");
    new PerformanceObserver((entryList) => {
      for (const entry of entryList.getEntries()) {
        const delay = entry.processingStart - entry.startTime;
        console.log('FID candidate:', delay, entry);
      }
    }).observe({type: 'first-input', buffered: true});
 }
</script> <script>if(window.location.pathname==='/gaming/'){if(document.getElementById('oi-spon')){document.getElementById('oi-spon').innerHTML='<a rel="nofollow noopener sponsored" href="https://www.10cric10.com/" target="_blank"> <div class="spon-txt" style="padding-top: 5px;">Powered by:</div> <div class="spon-img"><img data-pagespeed-no-defer src="/images/cric-logo.jpg" alt="10Cric India"></div> </a>'}}if(window.location.pathname==='/apps/news/'){if(document.getElementById('oi-spon1')){document.getElementById('oi-spon1').innerHTML='<a rel="nofollow noopener sponsored" href="https://www.guide2gambling.in/indian-casinos/" target="_blank"> <div class="spon-txt">Powered by:</div> <div class="spon-img"><img data-pagespeed-no-defer src="/images/g2g-small.jpg" alt="Indian Casinos"></div> </a>'}}</script> </body> </html>